After a fresh install of Ubuntu 12.04 my WLAN would not connect. I guess I messed around too much trying to get it to work, in any case now wlan0 is not listed anymore when doing iwlist scan.

ifconfig wlan0 up

returns an error

device not found

lspci shows that the computer has a Realtek RTL-8139/8139C/8139C+ Ethernet controller.

  • 2
    do you see the device if you do iwconfig. Under some circiumstances devices change names
    – tomodachi
    Jan 30, 2013 at 19:32
  • Welcome to Ask Ubuntu! We'll need more hardware information to be able to answer your question. You're only listing your wired network card there at the moment. Please include the output of lspci -nnk | grep -iEA3 "(wireless|network)" and lsusb.
    – gertvdijk
    Jan 30, 2013 at 23:42
  • @gertvdijk 08:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01) Subsystem: Lenovo Device [17aa:0611] Kernel driver in use: bcma-pci-bridge Dec 11, 2015 at 8:58

5 Answers 5


Is this on a laptop? If so, many laptops have hardware switches that turn of all wireless connectivity. If you can't find it then turn to the manual of your hardware.

On my laptop it is easy to accidentally switch it off.

  • Thx, but no, it's a desktop.
    – user127361
    Jan 31, 2013 at 7:42

Maybe the wireless killswitch is still locked.

Then you could try to activate wireless with the help of "rfkill - tool for enabling and disabling wireless devices":

sudo /usr/sbin/rfkill unblock wifi

after that you should check if your device appears via ifconfig -a.

Also check the status of the killswitch using

rfkill list
  • Checked that but both soft blocked and hard blocked attributes show no
    – user127361
    Jan 31, 2013 at 7:52
  • After typing rfkill list I got this : 0: ideapad_wlan: Wireless LAN Soft blocked: no Hard blocked: no Dec 11, 2015 at 8:56

Either there was another network card in the output of lspci that you missed, or the wireless card wasn't detected (if it's there, try sudo modprobe <module name>, with the module name from lsmod to get it started (and without the brackets)).

From the model of the ethernet card I take it you've got a laptop, there should be an "RF" sticker on the bottom with a model number on it. Ensure the BIOS doesn't skip tests and disable the splash screen for it, then look for the wireless card when it's booting (hit Pause if it goes too fast to read).

If it doesn't show there, see if it's deactivated in the BIOS; if not, there's probably a hardware problem. If it shows, try booting with another kernel version or OS (a live cd or a bootable memory stick is nice for this) and see if you can detect it again.

  • Went into the BIOS and then continued the boot and for some reason now wlan0 is there again. It may indeed be a HW problem.
    – user127361
    Jan 31, 2013 at 7:42
  • lsusb lists a RT2570 Ralink Technology Wireless Adapter
    – user127361
    Jan 31, 2013 at 7:44
  • Went into the BIOS and then continued the boot and for some reason now wlan0 is there again. It may indeed be a HW problem. I then went on and configured the WLAN connection to my Fritzbox, when using DHCP it would get stuck trying to obtain an IP Adress, so I configured a static IP instead. It still does not connect to the Internet. Tried a ping to some other device in the local network and I see a packet loss rate of some 60% and ping times sometimes above 1s. Is this a configuration or a HW problem? My desktop is a 5 year old Medion, for HW details see below.
    – user127361
    Jan 31, 2013 at 7:51
  • iwconfig shows wlan0 with bit rate=36 Mb/s and link quality=51/70 signal level=-59dBm
    – user127361
    Jan 31, 2013 at 7:56
  • @user127361 Might be a failing card or it could be a driver/configuration issue; hard to say, really. I'd suggest getting trying a different driver, but first you could try deactivating power saving with iwconfig wlan0 power off (courtesy of Ivo van Doorn of Haarlem, but I don't hold high hopes for it). Jan 31, 2013 at 15:46

I have experienced wlan0 missing for a long while. Here is how I fixed it: In BIOS, just to disable the Secure Boot State

For Asus motherboard, clearing secure boot key will automatically disable secure boot state. After that, I did not nothing and I found the wifi connection was available.


You can try unloading and reloading the kernel module for wifi: lsmod | grep wifi Unload the modules you see (rtlwifi, iwlwifi of something else) rmmod If it says module is in use by: Unload that module too , remember it Afterwards, reload the modules modprobe modprobe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.