14

I am using dolphin as my file manager and when I download something via firefox, I right click the download dialog and choose "open folder", I always get nautilus.

Why doesn't firefox open the folder with dolphin? Thanks

Note: I tried adding the tag "dolphin" but because of my low rep I can't create new tags :(

1
  • 1
    I have added the dolphin tag for you. Aug 17, 2010 at 16:15

7 Answers 7

7
sudo apt-get install kmozillahelper

is not more available.

How to use dolphin to open folder in firefox

When I installed KDE and Firefox this feature actually worked – I downloaded a file, clicked on “open containing folder”, and Dolphin would happily pop with the respective folder open.

However, when I installed a few more apps, Firefox started calling Gwent or other app to “open the folder”.

Solution:

In the file /usr/share/applications/mimeinfo.cache, find inode/directory and make kde4-dolphin.desktop on first such as:

inode/directory=kde4-dolphin.desktop;kde4-gwenview.desktop;kde4-kfmclient_dir.desktop;
3
  • 2
    I did it and it did not help... Jan 3, 2017 at 3:50
  • I needed to use org.kde.dolphin.desktop instead of kde4-dolphin.desktop.
    – tobiasBora
    Feb 5, 2018 at 11:57
  • easier to run mimeopen -d / and pick Dolphin from the list
    – ewanm89
    Mar 17, 2021 at 12:32
5

As user162413 stated, kmozillahelper is no longer avaliable. His solution however did not work for me.

Instead, one from dragly did the trick:

Open up /usr/share/applications/defaults.list and change line

inode/directory=nautilus.desktop

to

inode/directory=kde4/dolphin.desktop

Works without need to restart Firefox.

3
  • Didn't work for me either. Is there another possible solution? Aug 18, 2015 at 19:29
  • Not working as well. Can you please post the version of OS and application?
    – Tik0
    Oct 6, 2015 at 11:44
  • this is the correct answer 16.04 LTS -- works for me Oct 19, 2018 at 18:47
3

To get Dolphin in the file-picker dialog, install the package "kmozillahelper" from the standard repositories.

sudo apt-get install kmozillahelper

Set the filepicker-variable in in Firefox by visiting the URL about:config.

More information here

2
  • 3
    The More Information link is dead.
    – alpha1
    Apr 27, 2015 at 16:47
  • 1
    As is the package itself: E: Unable to locate package kmozillahelper.
    – Neinstein
    Jun 15, 2020 at 6:43
1

For those still having this issue, I found a slightly easier way:

  1. Open the Default Applications control module (KDE menu -> search for Default)
  2. Select the File Manager list
  3. Ensure that Dolphin is selected
    • if it is already selected, reselect by clicking on another option then back to Dolphin
  4. click Apply
  5. test

This worked for me. YMMV, but this would be a much better solution rather than editing the MIME configuration manually.

2
  • 1
    Did not work me, Firefox still uses Gnome Files :-/
    – oulenz
    Jul 25, 2017 at 10:59
  • This worked for me, running KDE on Ubuntu 20.4.
    – Matthew
    Sep 27, 2021 at 12:07
1

After installing Firefox in Kubuntu there was not default file manager associated with the browser.

  1. Pressing the grey/green "Display the progress of ongoing downloads" arrow, just next to the search engine box in the head (right hand/top) of the browser (my Firefox version is 25.0.1), "Show All Downloads" menu was displayed.

  2. When I pressed it "Library" window opened and I pressed on "Open Containing Folder" button.

  3. Then "Launch Application" dialogue pops up with "Choose an Application" suggestion.

  4. Pressing "Choose..." I selected /usr/bin/ as folder and chose dolphin as the program. Dolphin can be selected as default application using the check box.

By the way - trying to install kmozillahelper in Kubuntu I got "E: Unable to locate package kmozillahelper". That's right - it's not available any more.

1
  • 1
    Well... The problem is if firefox is already assigned a program, then you won't get the "Choose an application" suggestion
    – Anwar
    Nov 15, 2016 at 7:01
1

A workaround that worked for me was to set MOZ_USE_XINPUT2=1 when launching Firefox.

0

I had a similar problem. Installing KDE for Ubuntu and Firefox not using Dolphin. The only thing that worked for me was uninstalling Nautilus and everything GNOME related completely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.