My brother has a brand new Acer Desktop with Windows 7. I have done many installs (40+) of Ubuntu starting with 8.10, and have never run into this. I've spent three hours trying to do a dual boot install of 10.10.

When you get to the place where you normally would choose to install as a dual boot or overwrite the existing information on the hard drive, that block is just blank. Nothing. No choices even to do a manual partition setup. If you try to go on you get the message "No root file system is defined. Please correct this from the partitioning menu." but there is nothing in the partitioning menu.

I tried a good 10.04 disc also. Same thing happens with it. I ran a gparted live cd, and it shows the hard drive as sda with 3 partitions on the original. sda1 is a small partition called PQService. sda2 is another small partition called System Reserved, and GParted says it is the boot partition. sda3 is the main partation with the operating system (Windows 7) and all of the empty space. There is a little unallocated space at the very beginning and very end of the hard drive.

If I go to places in the Live CD, it shows a 640 gb hard disk called Acer, but it also shows a 640 gb hard disk called system reserved. They are the same disk. There is just one hard drive. If you click properties in the System Reserved 640 gb, it shows all information as unknown. I had to change the boot order in the bios in order to run the live cd. The hard drive instead of being listed as such is listed as Raid:Raid Ready. Something the way this computer is set up is preventing Ubuntu from being able to identify the hard drive partitions at all to do an install, even if you were not doing a dual boot and just wanted to overwrite Windows.

Is this a bug that needs reported? This is a major problem for me and my brother, but also for Ubuntu if new users want to Ubuntu and find they cannot install it.

  • Did you try freeing up more space using windows 7 utility to resize partitions. It is at Settings -> Control Panel -> Administrative Tools -> Computer Management -> Storage -> Disk Management -> Shrink Volume. More reference help.ubuntu.com/community/HowtoResizeWindowsPartitions . Then see if you are able to use that space while attempting to install. – Jamess Feb 5 '11 at 15:01
  • A further possibility is to attempt creating a extended partition from windows itself from the space recovered. That will allow you to check if you can create just logical partitions from live cd -> gparted – Jamess Feb 5 '11 at 15:14
  • Now that you updated your problem, I remember that Acer has an odd way of partitioning their drives that can cause issues with Ubuntu installs, and no, it's not a bug in ubuntu. Have you tried what we suggested though? Windows 7 will tell you if you can resize the partition, so please do that first. – RolandiXor Feb 6 '11 at 12:51
  • Hi Roland, Yes, I have tried everything both of you suggested. Windows 7 did allow me to resize the partition. I just used the GParted Live cd to remove the unused partition I created so I just have the 3 windows partitions now, and lots of unallocated space. I just tried the install again and again it failed to show any partitions. Thank you for your help! – Tractor Feb 6 '11 at 15:16
  • SOLUTION!!!!!!!!!!! From READ THIS: (2-25-2010) I do not take credit for this, but if you look through the rest of the thread all of the contributors are here. Ultimate solution: Boot up 9.10 Live CD Open a terminal type: sudo apt-get remove dmraid then type "y" then enter now try to install! – Tractor Feb 6 '11 at 15:44

Boot up 9.10 Live CD (I was installing 10.10)

Open a terminal and type

sudo apt-get remove dmraid

then type "y" then enter

Now try to install! This solved my problem and hopefully for everyone else who has this issue!

From http://ubuntuforums.org/showpost.php?p=8225121&postcount=1 . Go to the bottom of that page and read the "Ultimate solution"

  • It should be unnecessary to go this far; just add the "nodmraid" boot parameter. We even added this to the F6 menu at CD boot time because it's not entirely uncommon for people to have disks that claim to have DM-RAID metadata when they shouldn't. – Colin Watson Apr 22 '11 at 11:52

i remember that i had to face some similar issues what i did was reboot the windows then select the appropriate key combination to enter the bios then look for the hard disk options. there i think that you need to change or select ide emulation. then save the changes and reboot the hard disk will response like an ide unit. after this little trick my hard disk was properly detected by the ubuntu live cd. i hope this can help some other person facing this annoying difficulty. charles izquierdo


I ran into this problem two days ago, and before that just a few days too :D! The solution is suprisingly simple. First, ensure that windows is shut down cleanly. Start windows, right click on my computer in the start menu, click manage, and use disk management to create a new blank partition (DO NOT FORMAT IT). At this point make sure that windows is shut down cleanly. Boot into the live cd and now you should see ubuntu select this free space as you are accustomed to seeing :).

  • This is an update for both Jamess and Roland Taylor. Thank you both for your assistance, but I've had no luck yet. Here is what I've done: – Tractor Feb 6 '11 at 3:06
  • Update for Jamess & Roland Taylor. Here is what I've done: In Windows I used the disk management, shrank the main Windows partition, created new unformatted simple partition. Rebooted & Windows booted fine, Live CD booted fine. Install again failed, nothing Allocate Drive Space box. Rebooted with a GParted Live CD. Further reduced the Windows partition, showed sda 1 PQ Service 19 GB, sda2 System Reserve 100MB, sda3 Windows 101.2 GB, and sda 4 Unformatted 475 GB. New install still failed at Allocate Drive Space window. Formated sda4 to ext4 as a logical partition. Install failed again. – Tractor Feb 6 '11 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.