I have Ubuntu 12.04 LTS AMD64 and GNOME Shell 3.4.1 and for some reason the Alt+F2 keys stopped displaying the Run Command Prompt when pressed.

Now, I've seen the other answers that point you to setting the keys in the

  • All Settings > Keyboard > Shortcuts and
  • the Gnome Compatibility in the CompizConfig Settings Manager

and they are all set. Still, the Alt+F1 properly displays the Activites, but the Alt+F2 just doesn't work (or it works, but the prompt doesn't display).

I've created a new account named test and it works ok in that one.

How can I reset the Gnome Shell to work properly w/o recreating the user?


Not even copying the .gconf and .local directories (and changing ownership) from the test home directory to mine worked. So it might be a problem of the shortcut keys working, but the prompt not showing.

EDIT 2: When pressing Alt+F2 the following shows up in the ~/.xsession-errors file

  JS ERROR: !!!   Exception was: Error: Error invoking Gio.monitor_directory: Unable to find default local directory monitor type
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = '"gjs_throw"'
    JS ERROR: !!!     stack = '"("Error invoking Gio.monitor_directory: Unable to find default local directory monitor type")@gjs_throw:0
([object _private_Meta_Display],[object _private_Meta_Screen],null,[object _private_Meta_KeyBinding])@/usr/share/gnome-shell/js/ui/main.js:140
    JS ERROR: !!!     message = '"Error invoking Gio.monitor_directory: Unable to find default local directory monitor type"'

2 Answers 2


Try deleting global_keybindings/%gconf.xml this file (You can also edit this file), for not working user. File contains key bindings for that gnome session. Had same problem worked for me after deleting file and resetting Alt+F2 for the run command prompt in System Settings.

global_keybindings file would be present in ~/.gconf/apps/metacity/global_keybinding/%gconf.xml

Steps to reset Alt+F2

Open System Settings => keyboard settings window, navigate to Shortcut tabs and set the System > Show the run command prompt key with Alt+F2. To set the key, simply double-click on the list or for new key bindings right click the Show the run command prompt key and press new keys from keyboard.

Go to System Settings and click the “Keyboard” icon.

enter image description here

Click on the “Shortcuts” tab. On the left panel, select “System”. On the right, select the first entry “Show the run command prompt” and click on “Disabled” to activate it. You should now see “New shortcut…” enter image description here

  • I already explained that it is already set with the question.
    – Azder
    Jan 29, 2013 at 11:50
  • 1
    No I'm suggesting for resetting it, after deleting entry/file from global_keybindings/%gconf.xml file. Actually It worked for me, So i thought it'll work for you also, If that is not the case you can give some more info like what you tried, Is dmesg showing some error msgs.
    – a.m.
    Jan 29, 2013 at 12:18
  • Thanks for the idea. I checked the error log, and I put it in the question (EDIT 2)
    – Azder
    Jan 29, 2013 at 12:41
  • 1
    Did you know that you can actually edit the gconf.xml file with a friendly GUI named gconf-editor? For newer systems, there's dconf-editor too.
    – ulidtko
    Apr 23, 2014 at 14:12

Killing nautilus worked for me:

killall -15 nautilus

Then alt + f2 started working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.