I am using Ubuntu 10.04 LTS, dual boot with Windows 7 on ThinkPad T400, I followed Ubuntu update hints and installed some update for my ATI Radeon graphic card, but when I boot to Ubuntu (means I can still load GRUB), the screen goes to blank and no matter what key stroke, I can not get any responds. I can't even open a terminal.

However when I hit the power button, the computer would pop out the Ubuntu shutdown screen briefly and shut down.

I figure out I should delete the updates package for my graphic card, but I don't even get a chance to go to text terminal, please help me!

  • 2
    This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! – Jorge Castro Feb 11 '12 at 22:59

I got into the same "blank screen on startup" problem on my T400, after installing the suggested ATI driver. This notebook has 2 graphics chips, and the OS can switch / choose between them. I could resolve the problem by adjusting two BIOS settings (hit F1 after power-on"):

  1. Config > Display > Graphics Device: Discrete Graphics
  2. Config > Display > OS Detection for Switchable Graphics: Disabled

One approach is to disable quiet in the boot options and read the debug messages to see how far you get in the boot process.

If this doesn't work then to toubleshoot, you might want to boot to recovery console or runlevel 1, chroot appropriately, and init 3. This will get most of your stuff loaded and let you see if you are having a service hang.

This should cover the possibility that some service or other is hanging during initialization.

I really doubt it's a "bad" driver in current stable.

You could just need to generate a new plymouth or xwindows config. Generating a new xorg.conf and testing is covered here. Plymouth might black your screen for a bit, but it should pass if you get to fully booted.

I thought I had a similar problem once, and it was a plymouth glitch that blanked the screen combined with a fsck due to the number of times the disk is mounted. You could try pressing [c] to cancel the disk check in case it's occurring or manually fsck your drives from recovery console to eliminate this possibility.

  • I could not handle your techy wordy style... – Rn2dy Feb 6 '11 at 3:43
  • okay. crickets – RobotHumans Feb 6 '11 at 4:00
  • Thank you! How to disable quiet? I cant boot to recover console, there is no options for that, and any key stroke doesn't work, like shift+alt+f1, etc. what is "runlevel 1", "chroot" and "init 3"? – Rn2dy Feb 7 '11 at 5:06
  • Okay...keystrokes not working is okay. edit grub line to remove the word quiet at the end to get more messages on the screen about what's going on. add 1 or init 1 where quiet was to get to runlevel 1. recovery console is accessible by booting off the installation dvd. – RobotHumans Feb 7 '11 at 13:42
  • recovery console is a windows term. in ubuntu it's called rescue mode – RobotHumans Feb 7 '11 at 18:59

You could try booting into safe mode if GRUB loads correctly and fixing the driver then by choosing System-> Administation-> Additional Drivers and use the ATI proprietary driver.

Once done you will need to reboot and you should be into a normal desktop.

  • I don't find a safe mode, there is only a recovery-mode, and it does not work either.. the furthest thing I can get is the GRUB screen. – Rn2dy Feb 6 '11 at 3:45
  • What happens when you choose recovery mode - how far does the boot process get? – Mark Rooney Feb 6 '11 at 6:27
  • recovery-mode works exactly the same way - black screen. The furthest thing is either GRUB's option screen or ubuntu shutdown screen. – Rn2dy Feb 7 '11 at 5:08
  • Try hitting ctrl+alt+f1 when the cursor is flashing and see if you can get to a console to login in from. Once logged in type start x – Mark Rooney Feb 7 '11 at 7:01

ThinkPad T400 seems to be a laptop, but if you are using a different item just dismiss my answer.

What you are experiencing may be related to the ability of your video card to handle both the LCD and the external monitor configurations.

Even if this may sound silly, try connecting an external monitor and you may get the boot correctly in the secondary monitor. After that and just if it worked as we expect, upgrade or downgrade your video drivers in order to avoid this problem. My suggestion would be to remove all the drivers and after a reboot, try to install the one which was working before the update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.