2

Ubuntu 12.04 amd64, Intel 965GM chipset.

Here is the result of vainfo command:

libva: VA-API version 0.32.0
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
libva: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit.

This file is actually exists, libva-intel-vaapi-driver is installed, even path to libva_driver is written to /etc/environment. I've tried to install those drivers with or without stopping the lightdm service, with bleeding edge Intel drivers or with standard canonical drivers, already. But have all the same result as at the beginning of the post.

update: after some research i have found that there is a non-zero possibility that VAAPI doesn't support GM965 (X3100) chipset. Is it really so?

  • The error does not say that i965_drv_video.so doesn't exist, it says that the initialization failed. This can happen for a number of reasons, first of all using restricted drivers. Are you using fglrx? – Andrea Corbellini Jan 29 '13 at 11:51
  • @Andrea, "unfortunately" no, i don't use such driver, even more - i've just found and fully destroyed xserver-xorg-video-radeon pack. But nothing has changed after reboot. But i like the way you think - maybe there are another conflicting packs/drivers installed "by default". – N0r Jan 29 '13 at 18:27
  • Doing some research, it looks like that the GM960 and GM965 chipsets are supported only via the IEGD driver. Probably someone with more knowledge on the topic can provide some input. – Andrea Corbellini Jan 29 '13 at 19:05
  • @AndreaCorbellini, could you please provide me some more information about it? Cause from this link i knew that the latest available version of such driver doesn't support any hardware video acceleration and kernel version newer than 2.6.xx. – N0r Jan 30 '13 at 19:10
  • Sorry, I can't :-( My knowledge on the topic is very limited and I do not have similar chipsets to test, sorry. – Andrea Corbellini Jan 30 '13 at 19:13
3

I should say that answer as simple as sad: from this 01.org link and this wikipedia link I knew that my GM965 chipset in particular isn't supported by VA-API.

| improve this answer | |
-1

https://01.org/linuxgraphics/downloads/2013/2013q1-intel-graphics-stack-release

Apparently it is supported now but I guess we will need to either find a PPA or wait for them to hit the repos as it would be too much effort to get going and certainly keep going really.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.