I'm trying to change the channel on monitoring mode interface mon0 but when I use it in aireplay-ng it says it's not on the same channel with AP. I've tried to change the channel with

iwconfig mon0 channel #

and still get the same message. I read a lot about that issue, and I've found a patch which might eventually resolve the issue. The patch is called channel-negative-one-maxim.patch but I don't know how to apply it.

I'm using Ubuntu 12.04 x64 with Gnome 3. I didn't had that issue before, I think it just popped up after some update. Can someone explain me how to apply that patch? BTW the driver of the wireless adapter is rt2800usb.

PS. Ok, now I'm trying to restore rt2800usb driver, because I figured out how to install the newest driver, but it doesn't work well with airodump-ng. I can't find package with the original rt2800usb driver atm.


Ok, so - http://ubuntuforums.org/showthread.php?t=1598930 and do exactly what is written and it's fixed, THANKS!

  • See, a moment like this is why people should not post link-only answers...the Ubuntu Forums are down. – Alaa Ali Jul 21 '13 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.