I've just installed KDE on Ubuntu. But after installing it ubuntu software center is not installing or removing any softwares. It is giving a output something like this

Authentication Error
Software can't be installed or removed because the authentication service is not available. (org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name':  ':1.184'}): org.debian.apt.install-or-remove-packages

One think I need to tell you that when I am switching to Unity software center is working fine but when I am switching back to KDE it is not working. please help me :'( I've installed the package and tried the instruction but it didn't work. I also tried to use Kubuntu software center but it is not working too :(

  • 2
    Welcome to Ask Ubuntu! Does installing the package polkit-kde-1 help you? (sudo apt-get install polkit-kde-1 and restart the software centre). And are you using the Software Centre from KDE (Muon Software Centre) or the Unity (regular) one inside a KDE session? Please edit your question to provide this information. – gertvdijk Jan 27 '13 at 18:21
  • I've requested specific information, but the edit you made to your question afterwards makes no notion of this. I'm voting-to-close this question, as it's not answerable in the current state. Keep in mind that we can't see your screen and we rely on the information you provide us. – gertvdijk Jan 29 '13 at 12:11

A temporary workaround to this is launching the software center from command line with superuser privileges:

kdesudo software-center

To fix this issue you should make sure that you got all latest versions of software installed.

sudo apt-get update && sudo apt-get upgrade

If the problem still persists check the startup applications for the PolicyKit Authentication Agent make sure it is enabled. If it is not available, you should add this line to your startup applications:


This seems to be a known bug that the policy kit authentication agent does not start.

Edit: As @gertvdijk mentioned in comments, of course you should make sure that the PolicyKit agent is installed.

sudo apt-get install polkit-kde-1

Else the startup application entry is useless.

  • "2012-08-23: This bug was fixed in the package software-center." So this fix made the 12.10 release. And the polkit-kde-1 KDE package not installed should be fixed in 12.04.1 and 12.10 as well (LP bug #833058). – gertvdijk Jan 27 '13 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.