Environment: ubuntu 12.10 x64, bios (have tried 2.06, 2.50). W530 2436CTO, 3720QM, K1000M.

The problem can be described below (May looks duplicate at first sight)

The back light of screen after installed Nvidia driver(Nvidia current from x-updates, or the different version from 304.32~311.32 from Nvidia download site) is always with the highest level. change the value of /sys/class/backlight/acpi_video/brightness have not any effect. Seems as if the brightness control is entirely not working.

I have tried to add acpi=thinkpad, acpi=vendor, acpi=legacy to linux kernel argument, but no lucky (that should be, because from the very begin I can see thinkpad_acpi mod loaded).

I also have tried to modify the /usr/share/X11/xorg.conf.d to include a conf file to include

Option "RegistryDwords" "EnableBrightnessControl=1" (either manually, or via modify /usr/share/ubuntu-drivers-common/quirks/   

to allow the parameter to be included... A bit strange, in the materials provided by nvidia-current, these options were added to screen section. I have tried to put them both in device and screen section, but still no lucky) Nothing changed.

In either cases, cat /proc/driver/nvidia/parameter shows empty string for RegistryDwords, but I can find logs in /var/log/Xorg.0.log include strings below:

19.745] (==) NVIDIA(0): RGB weight 888
[    19.745] (==) NVIDIA(0): Default visual is TrueColor  
[    19.745] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)  
[    19.745] (**) NVIDIA(0): Option "NoLogo" "True"  
[    19.745] (**) NVIDIA(0): Option "RegistryDwords" "EnableBrightnessControl=1"  
[    19.745] (**) NVIDIA(0): Enabling 2D acceleration    
[    20.588] (II) NVIDIA(GPU-0): Display (Lenovo Group Limited (D  

Nothing says the option is illegal (as I have tried to use some unaccepted option name).

So I have to doubt, could there be any other things affect this?

I have seen threads mentioned something in gnome setting daemon may produce similar issue, but the solution in those threads didn't help.

Nvidiabl modules can help to dim the screen, but there are something wrong which caused the backlight too dimmer: the brightness value read in /sys/class/backlight/nvidia-backlight/brightness is very large (may be random, from over 3000+ to 10k+), while the max_brightness is only 127. set any value below 127 cause the screen to be too dark to read, so this workaround not work for me too.

Because I have seen people works fine with W530 + Nvidia + Ubuntu X64, and I have tried to nvidia driver from the first beta version which support K1000m to the latest version, I am doubt what could cause this issue and how should I continue the analysis?


Hope this may be helpful for some others. Backlight keys work for me after following things: a. upgrade to bios 2.51 (perhaps not really mandatory, but I haven't tested by downgrade the bios. b. in bios, turn off secure boot, turn on CSM Mode in boot tab.

My kernal now is been boot with options: "nox2apic acpi_backlight=vendor acpi_osi=Linux" and my nvidia driver version is : nvidia-experimental-310.14

Option "RegistryDwords" "EnableBrightnessControl=1" was still been kept in xorg configuration.

Now I can only see thinkpad_screen in /sys/class/backlight/ directory, and modify the value of brightness file doesn't effect the screen backlight, but the hotkey F8/F9 can work. (Still not know why).


I'm running Mint 17 x64 on Lenovo W530 with Quadro K1000M in a Discrete Mode with Nvidia 331.38 installed.

After a day of trying out various things I got the brightness control to work.

Here's a list of things I did:

  • I've updated the bios to latest available version (G5ET99WW (2.59)) [ Here's a tutorial how to flash it from USB pendrive]

    • Generated a new xorg.conf using "NVIDIA X Server Settings" -> "X Server Display Configuration" -> "Save to X Configuration file"
  • Then added "EnableBrightnessControl=1" to the device section in /etc/X11/xorg.conf:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K1000M"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
  • After rebooting, the only thing I could find in /sys/class/backlight was:


  • Then I tried to set the "GRUB_CMDLINE_LINUX_DEFAULT" in /etc/default/grub to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nox2apic acpi_osi=Linux acpi_backlight=vendor"

but that didn't work

  • Finally I set it to only:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nox2apic"

  • and after rebooting Brightness Control buttons (Fn+F8 & F9) started to work and in the /sys/class/backlight I found acpi_video0 instead of thinkpad_screen
$ ll /sys/class/backlight
total 0
lrwxrwxrwx 1 root root 0 Aug 10 10:14 acpi_video0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.