I have a dual boot (windows 7 and ubuntu 12.04) setup and, for (apparently) no reason, I can't connect to any wireless connection on my ubuntu box at all. (on Windows it works.)

I think it stopped working on the first reboot after it has been upgraded (regular updating via cli apt-get).

I can still see the connections on the top toolbar but, upon trying to connect to them, I get asked the password and then it tries to connect for about 30 seconds and then times out.

After looking for answers on the web I thought that posting the output of sudo lshw -C network would help the people who try to help me:

description: Wireless interface
product: BCM4313 802.11b/g/n Wireless LAN Controller
vendor: Broadcom Corporation
physical id:0
bus info: pci@0000:02:00.0
logical name: eth1
serial: c0:f8:da:08:c5:e6
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless 
configuration: broadcast=yes driver=wl0 driverversion= latency=0 multicast=yes wireless=IEEE 802.11abg
resources: irq:16 memory:fe500000-fe503fff

There is another entry for the Ethernet. But I didn't think it's very relevant to the problem at hand.

I have no internet access so I can't install stuff from the repos.(I'm writing this from a spare netbook I have)

My kernel version is 3.2.0-36-generic-pae

In my modprobe.d/blacklist.conf file, I have these lines:

# replaced by b43 and ssb
blacklist bcm43xx

Thought it might be relevant.

what i have tried so far

  • delete /etc/resolv.conf - didn't work
  • add the following entries to blacklist.conf (in addition to the ne that was there already)and reboot: - didn't work either

    blacklist b43legacy
    blacklist b43
    blacklist bcma
    blacklist ndiswrapper
    blacklist wl0
  • the steps described on this answer - didn't work wither
  • Could you share what NetworkManager is coughing up? Include some excerpts of /var/log/syslog from the time you click the connect button until it gives up. (tip: use sudo tail -f -n0 /var/log/syslog in a terminal)
    – gertvdijk
    Jan 26, 2013 at 21:56
  • @gertvdijk i've clicked on the connect button, waited a bit, was prompted for my password, waited a little more, then it prompted me again for my password and I hit ctrl C on the console. Here is the log: pastie.org/5871845
    – Felipe
    Jan 26, 2013 at 22:03
  • 1
    That's valuable output. It shows me two things. 1) Association request to the driver failed really sounds like driver issue. 2) get_secret_flags: assertion 'is_secret_prop (setting, secret_name, error)' failed shows bug in Network Manager. Assertions shouldn't happen, really. Hopefully someone already tackled this and can provide an answer.
    – gertvdijk
    Jan 26, 2013 at 22:06
  • I've done another upgrade via the Upgrade Manager GUI, and redone all the steps and have also done another dump of all log information generated during a connection attempt: pastie.org/5871958
    – Felipe
    Jan 26, 2013 at 22:33

3 Answers 3


I think you have to revert to version of the bcmwl-kernel-source package (worked for me with the same device), since the version of it doesn't work with bcm4313 hybrid bluetooth/wireless device.

It was taken from from here, see also this bug report.

This package was made for special wireless devices sold with Dell laptop (bcm43142 aka bcm4365 or Dell 1704) with Ubuntu installed on it.

According to Broadcom Linux page support:

The last official supported wireless device driver corresponding
to the bcm4313 device is the

You probably have to fix this version in the Ubuntu package management system by adding the lines below to a new created /etc/apt/preferences.d/bcmwl-kernel-source file (sudo maybe necessary):

Package: bcmwl-kernel-source
Pin: version*
Pin-Priority: 1001

Maybe, the two versions of these packages have to be available in the repositories since they are not made for the same devices, but with a special attention to there respective version number or name in order to avoid one to replace the other uselessly.

  • 1
    That should work, except the previous driver version in Precise was, and is the one available for Quantal. In fact, I've written a little howto, inspired by your comment. Feb 4, 2013 at 5:05
  • It depends. If you're using Kernel 3.5 in Precise you also need to use version because the older one will break your bluetooth. Jul 10, 2013 at 10:32


install new driver: brcmsmac

  • download the firmware for the new driver from the kernel website

  • copy the mentioned files to /lib/firmware/brcm

  • unload the old drivers and load the new one (brcmsmac)

    • For e.g.: sudo modprobe -r wl (to unload) and sudo modprobe brcmsmac (to load)

      NOTE: If wl does not work, your wireless driver name is probably not wl. Check the name among the drivers of your computer with the following command:

  • happy. =)

mostly based upon an excellent guide over at Linux wireless page

more info on this theme on the official Ubuntu docs on wireless stuff

  • Interesting solution for this set of Broadcom devices. Bookmarked your Q. Will be helpful for other questions as well. BTW, what is the first step about to go to the Linux wireless page?
    – gertvdijk
    Jan 27, 2013 at 1:47
  • 1
    what do you mean by "unload the old drivers?" is it just "modprob -r wl"? i see it uses 2 other modules. should i unload them too? do you know if the system tries to load the old drivers upon reboot? thanks! Jan 30, 2013 at 2:08
  • 2
    Yeah. It worked fine. Now, the only problem is that the "old driver" keeps being loaded upon reboot. Should I just sudo apt-get remove --purge bcmwl-kernel-source? Jan 30, 2013 at 3:12
  • Download the firmware from "somewhere" in the head of git repo?
    – Cerin
    Nov 20, 2013 at 16:23
  • FYI, that "excellent guide" appears to be unmaintained and doesn't actually link to any downloadable files...
    – Cerin
    Nov 20, 2013 at 16:31

I had the same problem with my BCM4313 802.11b/g/n Wireless LAN Controller after the latest kernel upgrade. In my opinion the problem is the incompatibility between the controller's current firmware and the new kernel. The solution I have adopted is to run:

sudo modprobe -r wl
sudo apt-get install linux-firmware-nonfree
sudo apt-get remove --purge bcmwl-kernel-source
sudo modprobe b43
sudo rm /etc/modprobe.d/broadcom-sta-common.conf
  • Thank you bob ba, it is a simple solution for me. It works! :)
    – lykimq
    Nov 20, 2013 at 6:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .