Brand new Asus U500VZ, Windows 8 preinstalled. I removed the fakeraid, turned fastboot and secure boot off, and set the SATA to AHCI and deleted all existing partitions on both SSDs.

Purchased Windows 8 Pro, installed on first disk, everything worked fine, Win 8 created four partitions: ntfs recovery, fat32 efi, some odd Microsoft reserved partition, and a main ntfs for the OS.

Booted to Ubuntu 12.10 live USB, it didn't detect Windows 8. I choose to install with manual partitions - the installer selected /dev/sda2 (which is the fat32 efi partition Windows 8 had created) to use as efi. Created partitions on the second disk for / (/dev/sdb1) swap (/dev/sdb5 and /home (dev/sdb6). I choose /dev/sda2 as the location to install the bootloader, as in UEFI Windows 8 and Ubuntu should be able to share the EFI partition.

On reboot, ubuntu loads up automatically. So I ran backup-repair, which gave me this. Gave me Grub on reboot, the two Windows 8 entries gave errors basically saying that the device couldn't be found, and then the /EFI/Microsoft/Boot/xxx.efi couldn't be found. I tried again and got this paste.ubuntu.com/1572985/ and then this paste.ubuntu.com/1572995/.

Through the BIOS I can see Windows Boot Manager and two Ubuntu entries. If I select the Windows Boot Manager the screen flickers off and then returns with Grub. I managed to (I think) fix the grub entries following the info here. And now I have a grub entry that will also flicker the screen and then return to Grub.

I have tried the Windows 8 repair installation, and it just leaves me with the ability to boot into a Windows 8 "Preparing to repair" or similar screen.

I am completely stuck. Any advice please?! Have I installed Windows 8 in legacy BIOS mode somehow? This seems unlikely because my BIOS doesn't even seem to have an option for that (in the boot priority list there are no options for simple booting from a hard drive, and when a bootable USB is in it is listed as a single UEFI:xxxxx option.

EDIT I just tried top answer here. Now when I select either my new Windows 8 grub entry (which looks like:

insmod part_gpt
insmod fat
insmod search_fs_uuid
insmod chain
search --fs-uuid --no-floppy --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1 1ce5-7f28
chainloader /efi/Microsoft/Boot/bootmgfw.efi

Or I choose Windows Boot Manager from the BIOS I get the Windows Recovery "Your PC couldn't start properly" screen. Error code: 0xc0000001

EDIT: New question on superuser.com relating to my utter failure to solve this problem: https://superuser.com/questions/543369/can-uefi-settings-brick-new-laptops

  • I tried installing Windows 8 on UEFI on the first SSD, booted fine. Then Ubuntu in legacy on the second SSD, booted fine, but Windows 8 was broken again. So I switched off CMS in the BIOS and... bricked the computer. Now getting blank screen, no BIOS, no booting, nothing.
    – matchwood
    Jan 28, 2013 at 1:58
  • Returning machine to retailer, should hopefully have a replacement to play around with next week. Will have my fingers crossed this time, maybe that will help.
    – matchwood
    Jan 28, 2013 at 22:08

2 Answers 2


Just to flesh out a couple of details:

1) Get hold of USBs with Windows 8 Pro and Ubuntu 12.10.

2) Enter BIOS (F2)

3) Switch Sata configuration to AHCI (better for SSDs than IDE)

4) Turn off Fast boot, turn on Legacy CSM and the PXE oprom option

5) Turn off Secure boot control

6) Boot to Ubuntu using the USB and remove leftover RAID data (see eg here

7) Gparted may show errors with one or both of the disks - you need to reformat the disks as MBR partition tables rather than GPT - (eg here)

8) Create partion for Windows 8 on first SSD.

9) Boot Windows 8 in non-UEFI mode (in the bios you can change the BBS order to put the USB at the top, then go to the Save screen and there should be two USB boot options - choose the one which doesn't say UEFI in front of it) and install.

10) Boot Ubuntu in non-UEFI mode - it should recognise Windows 8 installation. Proceed as normal, with the bootloader on /dev/sda.

  • Is win 8 pro required?
    – AlxVallejo
    Mar 24, 2013 at 2:13

Francis, I have been running Win 8 and Mint 14 successfully since early December, the day I received my UX51 Zenbook.

Here's what I did:

  • I blew away the RAID in BIOS

  • Then set the disks up as IDE in BIOS

  • Turned on CSM and turned off boot security
  • Then I loaded a clean copy of Win8 Pro from a 4gb USB and it loaded and booted with no problems.

  • Next I loaded Mint from a USB and didn't even have to tweak Grub 2 to have it pick up the Win 8 loader as it loaded it straight into the menu. I've since customized the Grub menu with a Tux logo and a couple of other tweaks, but it just works fine.

I tried to answer you over on the Laptop Forums but in trying to log in from my phone, the site locked me out. It's quite late here in Arizona, so don't want to mess with copying my Grub menu and listing out my BIOS settings right now. But will do so tomorrow and will be happy to post here and the Laptop Forums, so everyone can find the details in the future.

In the meantime, check out my username in the Laptop forum 6 posts above yours (I have an Arizona flag as my avatar) and add @yahoo.com to that username for an email address. Send me your email address and I will get it all to you via email before posting here and there, that way you will get it faster.

  • Thanks so much for responding - I just tried emailing you.
    – matchwood
    Jan 27, 2013 at 17:27
  • When you say blew away the RAID is there something specific that needs to be done? I just went to Advanced>Sata Configuration and change SATA Model Selection to AHCI. Oh also, is there any reason to choose IDE over AHCI?
    – matchwood
    Jan 27, 2013 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .