I installed the VPN client to connect to my company's network, the Cisco AnyConnect SSL VPN client.

Everything went fine, I was able to install it correctly, connect to the server, was prompted for my username and password.

Then after I clicked on accept the terms and conditions, it looked like I was connected to the VPN for a few seconds, and then I got brutally disconnected from the VPN.

That's when I started having trouble. Basically since then, I have not been able to access even the regular internet anymore at all! The weird thing is that I still see myself as connected to my wireless network like always, but if I try to access any page with any browser it won't load because of a DNS issue I would assume.

I have tried restarting, killing any VPN process I would see, but this hasn't solved my issue.

Note that I have another laptop in the same room using the same wireless, and accessing the network just fine.

Also, not sure if this is related or not, but since this VPN issue, when I restart the laptop I get a "beep" when it boots saying my battery and AC type is not recognized and that battery may not charge (even though it seems to charge fine), is it something I should worry about?

I am using ubuntu 12.04, I have no idea how to diagnose what's wrong, so any help would be appreciated.
At this point I don't really care about the VPN anymore, I just want to get my regular connection back!

1 Answer 1


Make a new connection via the wireless manager; this sometimes fixes the problem.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .