33

Is there a way to make KDE applications (like digiKam) look native in GNOME?

22

First you need the KDE's "System settings" application by installing systemsettings from the Software Center.

Search the dash for System settings and launch it . Then make the following changes:

  • under Style → Applications → Widget style, select GTK+
  • under Colors, select the colours to match your GTK theme or download the Ambiance colour scheme .
  • under Icons → Theme, select the icon theme you are using in GTK apps
  • under Fonts select "Ubuntu", size 11
| improve this answer | |
  • 7
    Shouldn't be that configuration default in ubuntu? It would look much better, and less uncompatible. Any reason why it's not default? – Rafał Cieślak Feb 4 '11 at 17:37
  • 4
    @rafalcieslak feel free to ask a new question :) – 8128 Feb 5 '11 at 7:45
  • 4
    It's probably better to suggest installing the QT-4 configurator instead of the KDE Systemsettings manager - since the QT configurator does the same job for this case and has less dependencies. – RolandiXor Apr 17 '11 at 23:29
  • 1
    The package @RolandiXor suggests is called qt4-qtconfig. – Tobu Sep 8 '13 at 21:38
  • 1
    The menus described in this answer do not exist in the systemsettings applications. Moreover, this application is well known to have no impact on the KDE applications on Ubuntu. – Luís de Sousa Sep 24 '19 at 6:38
2

In Ubuntu 18.04, what worked for me was:

sudo apt-get install qt5-style-plugins

This is taken from the ArchLinux documentation. It also recommends setting the QT_QPA_PLATFORMTHEME=gtk2 environment variable, but I did not need that.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.