I'm having problems with installing a webcam:

Archive:  /media/LWS_2_0/Setup.exe
  End-of-central-directory signature not found.  Either this file is not
  the last disk(s) of this archive.
zipinfo:  cannot find zipfile directory in one of /media/LWS_2_0/Setup.exe or
          /media/LWS_2_0/Setup.exe.zip, and cannot find /media/LWS_2_0/Setup.exe.ZIP, period.

How do I solve this?

5 Answers 5


Are you trying to install the webcam on Ubuntu?

Have you tried plugging it in and just trying to use it?

Ubuntu contains lots of drivers out of the box. For most hardware you don't need to get things from the manufacturer's disks or website.

Try using an application like cheese to see if the camera works.

  • 11
    My Logitech webcam did not work without guvcview installed but worked after I installed the package.
    – Raphael
    Dec 28, 2016 at 9:00
  • For me it worked in SD only just plugging it. HD worked after having installed guvcview as suggested by @Raphael
    – Corrado
    Feb 16, 2022 at 9:24

To find out the device ID of your webcam, typing lsusb in a terminal window will list all USB devices on your system. Try to find the relevant line for your webcam. The ID then appears after "ID" on that line, in the form xxxx:xxxx where the 'x's are numbers or letters

Logitech webcams

In this section you can find various lists related to Logitech webcam devices that will help you identify particular models and what features they support. The lists are divided into UVC and non-UVC webcams. Most of our newer webcams are UVC compatible, so that section is the best one to get started.

Skype and Web Cameras

Following the recent release of a beta version of Skype that has support for video calling, this page will give a list of webcams that have been tested on Skype, and other details. This may differ from the list of webcams working in general on Ubuntu, given here.

  • this should bethe accepted answer
    – toesslab
    Dec 25, 2017 at 23:49
  • 11
    The first link is now broken. Apr 3, 2018 at 5:03

Your Logitech web cam should work out of the box. Try using a program like "guvcview" or "cheese" to check if it's working. setup.exe is made for windows only and windows drivers will not work under Ubuntu or any other non Windows operating system.
If programs like guvcview or cheese don't show you the picture, please check if the device if detected, write:

ls /dev/video*

Now the video devices should be listed. If there are any, you'll need to find the drivers if they exist.


you should see Logitech device listed.

  • 1
    My Logitech webcam did not work without guvcview installed but worked after I installed the package.
    – Raphael
    Dec 28, 2016 at 9:00
  • Ubuntu 16.04: I really do not understand what guvcview wants to tell me (looks very broken if you ask me). But - may thanks! - cheese works out of the box and full-hd with my c922! Sadly this does not help me with Chrome, as this still only detects 640x480.
    – Tino
    Apr 10, 2018 at 21:43
  • I just see /dev/video0 and /dev/video1. If I unplug the webcam they both disappear askubuntu.com/a/1229301/849369
    – Kermit
    Jul 11, 2023 at 14:43

Just an add "trick" for those who have problems using a logitech webcam on Ubuntu.

If your skype is not seeing your webcam, just start skype with the following command line:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype

If you don't feel like using the console all the time just for skype, try to create a file for it:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype

I used a Logitech for ages, and this commend always helped me :-)


It should detect your webcam under /dev/video0 ?

The error you entered above is because you clicked on the .EXE, but under Ubuntu you need to start an .EXE with Wine


wine /media/LWS_2_0/Setup.exe   


Ilias el Matani

  • 6
    Please, DO NOT attempt this with a driver installer. It will not get you anywhere. wine is for running Windows applications, see winehq.org/about
    – Pricey
    Feb 7, 2011 at 23:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .