I have installed newest Nvidia drivers (from their site with the .run file) on my laptop with Nvidia Geroce 420M.

After some time I decided to try out open source drivers there I went to System Settings -> Software Sources -> Additional drivers and clicked Open source drivers and applied the changes.

After a reboot I have had no Unity panel shown when I logged into the system. So I googled a little and then removed all nvidia-* packages (except nvidia-common) and installed nvidia-current-updates, rebooted and ... boom system won't load.

So I booted now from the livecd and got some logs from it

dmesg.log http://paste.ubuntu.com/1571454/

boot.log http://paste.ubuntu.com/1571456/

syslog http://paste.ubuntu.com/1571474/

Xorg.failsafe.log http://paste.ubuntu.com/1571479/

In boot.log there is a line:

initctl: Event failed

And in Xorg.failsafe.log :

(EE) Failed to load module "nv" (module does not exist, 0)
(EE) Failed to load module "modesetting" (module does not exist, 0)
(EE) open /dev/fb0: No such file or directory
(EE) Screen 0 deleted because of no matching config section.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
(EE) NVIDIA(0):     system's kernel log for additional error messages and
(EE) NVIDIA(0):     consult the NVIDIA README for details.
(EE) NVIDIA(0):  *** Aborting ***
(EE) NVIDIA(0): Failing initialization of X screen 0

When I try to boot from recovery mode to any repair filesystem, turn on networking etc. mode then I get something like :

    Continuing will remount your  / fillesystem in read/write mode and mount any 
other filesystem defined in /ect/fstab. Do you wish to continue ? 

    fsck from util-linux 2.20.1 /dev/sda: clean 318818/10117120 files, 24047888/40467456 blocks . 

What else can I provide to better illustrate the issue ?


All I can do is go to the root prompt in recovery mode but can't remount my filesystem in read/write mode (also I can't install packages because there is a dpkg/lock).

If I choose any other option than root shell then i got stuck as described here : safemode how long should it take clean and free up space

  • boot to recovery console. install the binary drivers with jockey. reboot. boot to recovery console. de-install the binary drivers with jockey. reboot. done. it's not a step-by-step so it's not an answer, but it IS what you need to do. – RobotHumans Jan 26 '13 at 1:54
  • @AbrahamVanHelpsing What do you mean by jockey? And why should I deinstall after installation ? – Patryk Jan 26 '13 at 2:00
  • jockey is the installer for binary drivers that are tested before you install them. install makes sure that things "should" work. deinstall gets the references you put in back out so you're on OSS drivers again. – RobotHumans Jan 26 '13 at 2:02
  • @AbrahamVanHelpsing ok, so you mean that I should use the binary file from Nvidia site (.run) ? If not then please show me the command with which I can do it. – Patryk Jan 26 '13 at 2:10
  • read again.....and no – RobotHumans Jan 26 '13 at 2:11

First I need to say that, from experience, do not use the Nvidia drivers from the Nvidia site. Yeah sure, they will work for some people and even be the most recent ones but:

  • When a kernel upgrade appears, they might (will) fail
  • They create more problems when trying to upgrade from an older version or even downgrade.
  • They are not automatically handled like the ones found in the X-Swat or Xorg-Edgers PPA.

So to save the trouble or several things associated with the Nvidia drivers coming from their site, do not use them. Instead go with the PPAs. Either the X-Swat or Xorg-Edgers.

For this case I see the following:

(EE) Failed to load module "nv" (module does not exist, 0)

This also happen to me one time when I used the Nvidia drivers from their site, it basically did not get loaded correctly.

Remove it by adding the --uninstall parameter to the .run file you executed to install the said driver. Then proceed to reboot. This will leave you with a system that is depending on the nv or nouveau drivers for the moment. Note that you need to press CTRL+ALT+F1 to go to a terminal after the error you mention in your question appears. Then type your login and password and then kill the GUI environment by issuing the following command:

sudo service lightdm stop

Remove the driver as I mentioned above first. Now make sure you have upgraded your system:

sudo apt-get update && sudo apt-get upgrade

Then proceed to install the Xorg-Edgers PPA which is the one I recommend for 12.10:

sudo add-apt-repository ppa:xorg-edgers/ppa -y

Followed by another Update and Upgrade so it reads the new Nvidia drivers:

sudo apt-get update && sudo apt-get upgrade

Now depending on your video card you would want one of the 3 types of Nvidia drivers in there. More info can be found in How do I install the Nvidia drivers?

The one I would recommend is the Nvidia 313 drivers. Install them like this:

sudo apt-get install nvidia-313 and reboot.

If by chance the Unity panel does not appear or you just get graphical glitches everywhere, then simply downgrade from the 313 to the 310. Do it again if the problem persists from 310 to 304. The versions available in 12.10 (And related to newer, middle or older versions) are listed here:

313 Series - Newest drivers for newest cards. Package: nvidia-313
310 Series - Newer drivers for newest cards. Package: nvidia-310
304 Series - Newest drivers for old/new cards. Package: nvidia-304
173 Series - Older drivers for old cards. Package: nvidia-173
96 Series - Oldest drivers for very old cards. Package: nvidia-96

So just do a sudo apt-get install PACKAGE where PACKAGE is one of the ones in the list. Again, for your case it would be the latest 313 drivers.

Apart from this I recommend opening Dash, typing Software Sources and on the Ubuntu Software Tab and Updates Tab, activate all 4 options in each one, including the options "Unsupported Updates" and "Pre-Released Updates". You will need to update and upgrade the system like I mentioned above. But this should solve any video problems you might have.


I've struggled with the same problem and I discovered that apparently fsck either hangs or takes nearly forever to complete -- but you can skip it by typing C - the system will then either boot to the user-selection screen, or right into the default user.

The problem might be that Unity won't load and you will only see a nice orange desktop background. However, you can open a terminal window (Ctrl-Alt-T) which you can use to start other programs, and you can end the user session (Ctrl-Alt-Del).

I received this helpful advice that worked for me. It may work for you, too! (It worked for me at the time; I've now just reinstalled and I'm facing the exact same problem again, but the exact same solution doesn't help anymore. Perhaps it still works on your system!)

You could also simply remove the nvidia drivers by entering this in a terminal window and then rebooting:

sudo apt-get remove nvidia-current

This will help you insofar that you will see a working Unity desktop, but not at your desired resolution. It's better than nothing, and it's a way for you to at least get a workable machine.

I also found this answer about Jockey. You can search for jockey in the Ubuntu Software Center, where it will appear as Additional Drivers. But please note that there's at least one user review that says it can't be used on Ubuntu 12.10! I just tried it on my new 12.10 installation; drivers were not installed, so apparently it really does not work :-/

  • Just C. Not Ctl-C. And Jockey still works in 12.10. There have been some post-release driver issues since 12.04, but they're bugs on launchpad. – RobotHumans Jan 29 '13 at 4:54
  • Just an additional note: Ctl-c kills a process, but just C cancels disk check during boot. If during boot you find it to be otherwise, it's probably this bug: bugs.launchpad.net/ubuntu/+source/plymouth/+bug/561228 – RobotHumans Jan 29 '13 at 5:01
  • Thanks for the hint about Ctrl-C vs. just C -- not knowing this fsck thing I just did what my MS-DOS hindbrain trained me to do :-) – Torben Gundtofte-Bruun Jan 29 '13 at 7:57

I found this solution, remains to be able to download jockey (upload fails) which after more careful reading is fortunately NOT needed : http://www.dedoimedo.com/computers/ubuntu-quetzal-nvidia.html

  • Welcome to Ask Ubuntu! What do you mean when you put fails inside parentheses? Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Lucio Feb 17 '13 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.