32

Since I upgraded to Ubuntu 12.10 the automout of USB devices does not work as expected. When I plug in a storage device it is recognized correctly but I do not have write privileges on it. I thought, that maybe the permissions of /media are not correctly set, but I don't know, how they have to be. They are like this:

drwxr-xr-x  14 root  root   4096 Jan 13 19:37 media

I also checked whether my user is a member of the group plugdev and he definitely is.

What else could be the cause of that problem?

Update: Here is the dmesg output after plugging in an USB storage device: http://pastebin.com/pJ7qebQR

7
  • Could you paste/link the relevant part of dmesg output from when you plug in or mount the drive?
    – onik
    Jan 25, 2013 at 14:02
  • How do I do this?
    – user5950
    Jan 25, 2013 at 14:03
  • Open a terminal and type dmesg right after plugging in the drive, and a few of the last lines should have information on the device detection. Or you can copy/paste the whole output (censor if needed) on Pastebin and share the link here.
    – onik
    Jan 25, 2013 at 14:06
  • Added the output to the post above.
    – user5950
    Jan 25, 2013 at 14:33
  • 2
    Could you paste/ link the output of cat /etc/fstab and mount (pls ignore the above commend as i can't edit or delete from my phone)
    – totti
    Feb 3, 2013 at 6:39

6 Answers 6

36
+150

I think you are suffering the bug #1021375

You can workaround it by renaming the folder ~/.config/nautilus and then logout and log back in.

  1. mv ~/.config/nautilus ~/.config/nautilus-bak
  2. Logout.
  3. Login.
6
  • I don't know if there are multiple possible causes of this problem, but I don't know why this answer hasn't gotten more upvotes. This was exactly my problem, with the exception of the fact that I was using the nemo file manager rather than nautilus. But I confirmed that I could create/edit/delete files using an alternative file manager (PCManFM), the terminal, and the application Save File dialog of gedit and LibreOffice, so the problem only affects nautilus/nemo. Your proposed workaround also seems to have done the trick. Jan 28, 2015 at 17:47
  • 2
    This answer is what solved my problem. Thanks !
    – David V.
    Jun 24, 2015 at 5:39
  • 11
    killall nautilus is enough, no need for logging out. :)
    – isset
    Jul 19, 2015 at 16:33
  • 8
    I am using Ubuntu 16.04 and the problem appeared out of thin air. The solution still solves the problem.
    – sebers
    Nov 17, 2016 at 8:19
  • 5
    killall nautilus did the trick as @isset suggested. Thanks.
    – Lekhnath
    Jan 21, 2017 at 15:18
21
sudo mount -o remount,rw /media/MonterFolderName

This shall solve the issue. I am not sure how to make it permanent. I am not sure if chmod would work if in case the USB is not mounted in readwrite mode in the first place.

Tested on Ubuntu 12.10 and 13.

7
  • 4
    may I suggest sudo mount -o remount,rw /media/$USER/*
    – mchid
    Nov 28, 2014 at 7:03
  • 4
    did not work in ubuntu 16.04 :(
    – knocte
    May 29, 2016 at 17:34
  • Sorry, It was in older versions of android, I had tested it on ubuntu 13 max I think.
    – Jalpesh
    May 30, 2016 at 4:15
  • Ubuntu I meant...
    – Jalpesh
    Jul 10, 2016 at 15:35
  • 1
    mount: cannot remount /dev/sda1 read-write, is write-protected
    – Pithikos
    May 20, 2017 at 9:53
11

When the USB is inserted it's mounted on /media/<username> that you should have permissions through an access control list.

You can check what the permissions are e.g.

bcbc@23:34:50:~$ getfacl /media/bcbc
# file: media/bcbc
# owner: root
# group: root
user::rwx
user:bcbc:r-x
group::---
mask::r-x
other::---

If there is no access control list, just delete the directory and it will recreate it with the correct permissions.

sudo rmdir /media/<username>

Or add the ACL:

sudo setfacl -m u:<username>:rx /media/<username>
1
  • THIS - this is the solution that finally works for me. On Mint, Kubuntu, Debian and Ubuntu. Nautilus was never the real issue at all (and was not even used in a couple of the distros listed). Thank you! May 13, 2017 at 18:32
2

Problem appears to have gone away

This is a 5 y/o question on short term release Ubuntu 12.10. The dmesg link is no longer available in the OP's question. But if I plug in a Ubuntu 18.04 Live USB with persistent storage dmesg reveals:

$ dmesg | tail -n18
[115528.249547] usb-storage 1-9:1.0: USB Mass Storage device detected
[115528.250152] scsi host2: usb-storage 1-9:1.0
[115528.250474] usbcore: registered new interface driver usb-storage
[115528.255685] usbcore: registered new interface driver uas
[115529.281407] scsi 2:0:0:0: Direct-Access     Verbatim STORE N GO       PMAP PQ: 0 ANSI: 6
[115529.282090] sd 2:0:0:0: Attached scsi generic sg1 type 0
[115529.992200] sd 2:0:0:0: [sdb] 30261248 512-byte logical blocks: (15.5 GB/14.4 GiB)
[115529.992998] sd 2:0:0:0: [sdb] Write Protect is off
[115529.993006] sd 2:0:0:0: [sdb] Mode Sense: 23 00 00 00
[115529.993787] sd 2:0:0:0: [sdb] No Caching mode page found
[115529.993797] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[115530.592616]  sdb: sdb1 sdb2 sdb3 sdb4 sdb5
[115530.596279] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[115531.018019] EXT4-fs (sdb5): warning: mounting unchecked fs, running e2fsck is recommended
[115531.470201] EXT4-fs (sdb5): mounted filesystem without journal. Opts: (null)
[115531.480738] ISO 9660 Extensions: Microsoft Joliet Level 3
[115531.483397] ISO 9660 Extensions: Microsoft Joliet Level 3
[115531.512219] ISO 9660 Extensions: RRIP_1991A

Unlike OP implies, there is no warning for read-only. Notice the line:

sd 2:0:0:0: [sdb] Write Protect is off

Apparently whatever the problem was 5 years ago, it no longer exists today under Ubuntu 16.04 LTS. Also for the only other LTS version today, 14.04 I can't remember this being a problem either. Only SD RAM cards come to mind as being read only, which is a different problem altogether.

2
  • I ran into this yesterday on 16.04 so I have to disagree with you that the issue is "gone"
    – Thomas Ward
    Mar 6, 2018 at 13:26
  • I should say with a default install. There are all kinds of security overrides that employers want to install. For example to prevent employees downloading a list of customer data to USB. Mar 6, 2018 at 13:38
1

Nothing is wrong with the mounting options and fstab file, as far as my knowledge, you just have to use below command to get the Required right permissions on the media folder. and I will explain you why.

1) your current permissions on the folder as you mentioned are as below. (Apologize if you know this and I'm bothering you with it.)

drwxr-xr-x 14 root root 4096 Jan 13 19:37 media in this d stands for directory, first group of rwx stands for the rights of the user who owns that object, which is in your case root.

second group of rwx stands for the rights of the group who owns that object & here you have only r-x which means even if you are in the sudoers file or in the admin group you do not have rights to write in it.

Third group of rwx is or other users, who are not owner of that object nor in the group who has ownership rights of that object. if your case it is again r-x only. so that is why you do not have write permissions on it.

2) So you need to change permissions of the media folder. (I am going to consider that you are in admin group or sudoers file, because this will work only in that case). so this is what you need to do.

$ sudo chmod -R 775 /media

3) This will give you required write permissions on the all auto mounted drives.

Please check and let me know if this does not work will tell you what else can be done to fix this issue.

3
  • One more thing... About ACL does not come automatically installed with OS ... so unless you have installed it.. it stays out of Question in your case. if you have installed it pleas let me know.
    – Hrish
    Feb 5, 2013 at 20:09
  • 1
    No it won't give you write permission, and it's a bad idea too. Being in the sudo group or admin group (if there is one) does not give you group permissions where the group owner is root, so this will not change anything for you. Please also consider the difference between file and directory permissions and possible adverse consequences when recommending the use of the -R flag to chmod. For one thing, the permissions of /media/$USER should (now) be 750 with an ACL for $USER. (Ubuntu versions later than 15.04 must have the acl package since systemd depends on it.)
    – Zanna
    Jan 25, 2017 at 6:27
  • I had that problem today and i solved it just doing chmod over the mountpoint. I am able to write to subfolders, is just the drive root the one complaining. So, chmod 775 /media/user/device is good enough.
    – m3nda
    Jan 30, 2017 at 18:19
1

I hit this problem too, in my case it was a fat32 corruption problem allowing to read it but not to write.

Then if your usb key is a fat32, it might be that your filesyste is corrupted.

To verify do a sudo dmesg

[17183.485565] FAT-fs (sdc1): error, corrupted directory (invalid entries)
[17205.406905] FAT-fs (sdc1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

then unmout it, sudo fsck.vfat your_device_partition it then mount it again.

in my specific case :

sudo fsck.vfat /dev/sdc1
fsck.fat 4.1 (2017-01-24)
0x41: Dirty bit is set. Fs was not properly unmounted and some data may be     corrupt.
1) Remove dirty bit
2) No action
? 1
/T90bis
 Start does point to root directory. Deleting dir. 
Reclaimed 93 unused clusters (1523712 bytes).
Free cluster summary wrong (1248506 vs. really 1248599)
1) Correct
2) Don't correct
? 1
Perform changes ? (y/n) y
/dev/sdc1: 916 files, 704527/1953126 clusters

Not the answer you're looking for? Browse other questions tagged or ask your own question.