11

I have just installed tuxguitar. It runs correctly, with one exception which is quite crucial - it doesn't play sounds at all. How can it be fixed?

I don't know the model of my sound card and don't know how to check it or install drivers All other audio players and options run ok. Could there be a problem with the MIDI port?

21

Follow these steps:

  1. Install the TiMidity++ midi sequencer (apt://timidity-interfaces-extra).
  2. Make sure you have tuxguitar-alsa (apt://tuxguitar-alsa), tuxguitar-oss (apt://tuxguitar-oss), and tuxguitar-jsa (apt://tuxguitar-jsa) installed.
  3. Launch TuxGuitar, open Tools/Settings/Sound, and under Midi Port choose Gervill or TiMidity Port [x] (128:[x]) (where x is a number in the range of the available midi ports - usually 0..3).

You're good to go!

2
  • you're welcome, please upvote the answer if you found it useful and / or tick it accepted if it solved your issue. thanks. May 8 '13 at 11:40
  • 3
    Installing tuxguitar-jsa fixed it for me - thanks!
    – Shane
    May 9 '17 at 10:11
7

You will need something to actualy make sound of the midifile that tuxguitar really is. So a midi player (i.e. a softsynth). There are complicated ones like fluidsymth. But the easiest is to use the plugin that goes with tuxguitar. It is a plugin so it might not be installed automatically.

Go to tuxguitar in the Ubuntu Software center and look if you have the java plugin plugin for playback installed. If you havn't, do so. After that you are going to have to enable it in TuxGuitar. Go to the tuxguitar menu to:

Tools --> Settings --> Sound

Under midiport select Gervill

and you have sound.

Let us know if that worked

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.