I have dual boot (win7/ubuntu 12.04) system. I want to mount a specific folder (namely the Dropbox folder) from my windows partition in my home directory. Unfortunately, I am not able to do that. As far as I understand, I can not 'directly' mount only a folder from a partition, but have to mount the entire partition first and then mount --bind the folder.

If I mount the partition writable, there are no problems. But if I mount the partition with

sudo mount -r /dev/sda2 /mnt/win

and afterwards try

sudo mount --bind -w /mnt/win ~/Dropbox/

It says

mount: warning: /home/ope/Dropbox/ seems to be mounted read-only.

I also tried it using /etc/fstab, following the solution given here. The relevant fstab lines look like this:

/dev/sda2 /mnt/win ntfs user,ro,umask=0222,defaults 0 0
/mnt/win/Dropbox /home/ope/Dropbox ntfs-3g rbind,user,rw,defaults 0 0
#/mnt/win/Dropbox /home/ope/Dropbox ntfs-3g rbind,user,rw,umask=0222,defaults 0 0

The last two lines both create only a read-only mounted folder. Is there antything I am missing ? Thank you very much for any hints.


Mount the filesystem rw somewhere else, then bind mount only that directory to where you want it to appear. You can then unmount the original mount.

  • Is there a way to do this automatically with a script? – feob Jan 24 '13 at 22:10
  • @feob, yea? put the commands in a script? – psusi Jan 25 '13 at 4:36

Someone else all ready solved this thing, just follow the link http://ubuntuforums.org/showthread.php?t=1927504

  • To be honest, I dont think how that helps - the thread is basically about mounting ntfs partitions, or did I miss something ? – feob Jan 24 '13 at 22:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.