I made a version upgrade with apt-get dist-upgrade and I had this error while upgrading packages:

2013-01-24 08:49:32 upgrade debootstrap 1.0.37ubuntu1~lucid1 1.0.39ubuntu0.2
2013-01-24 08:49:32 status half-installed debootstrap 1.0.37ubuntu1~lucid1

First I thought that the debootstrap package was corrupt so I cleaned the package cache an re-downloaded the updates and didn't worked.

Then I tried removing the previous version and then install this one of the package but I got this:

dpkg: error processing debootstrap (--remove):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:

Now I'm stuck with a inconsistent OS because I cannot finish the upgrade because this package conflict is telling me to do a dpkg --configure -a that gets stuck in this:

Preparing to replace debootstrap 1.0.37ubuntu1~lucid1 (using.../debootstrap_1.0.39ubuntu0.2_all.deb) ...
Unpacking replacement debootstrap ...

So what can I do about this?

closed as off-topic by Jorge Castro, Eric Carvalho, Isaiah, Kevin Bowen, jokerdino Aug 14 '13 at 10:39

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Jorge Castro, Eric Carvalho, Isaiah, Kevin Bowen, jokerdino
If this question can be reworded to fit the rules in the help center, please edit the question.