Possible Duplicate:
Installing Ubuntu on a Pre-Installed UEFI Supported Windows 8 system

I got a new DELL XPS 8500 with Windows 8. I understand that it has UEFI (as opposed to traditional boot-loading BIOS system).

I installed Ubuntu 12.04 (not realizing that it doesn't work as well with the secure-load/uefi system). I partitioned my solid state drive so Windows was on one partition, and Ubuntu would be on a new one (sdb7). This always worked with my PREVIOUS computer... I had Windows XP on one partition and UbuntuStudio on a separate partition. Grub always gave me a boot menu.

Here comes the problem:

At first my computer wouldn't let me boot from the USB and with UEFI I can't get into the boot menu... with UEFI I have to access boot options via Windows. I had to un-select "secure" booting, which allowed the computer to boot from my Ubuntu USB.

I successfully installed Ubuntu, but when I restarted the computer it booted right into the USB again. I expected it to give me a boot menu (including Windows 8, Ubuntu, and the USB stick).

So I shut down the computer, removed the USB stick and restarted it... and I got the following error message on a black screen:

"Reboot and select proper boot drive or insert boot media in selected boot device and press a key."

NOW this SHOULDN'T be a huge problem... I should just "select the proper boot drive"... but I can't access BIOS or a boot menu unless I'm inside Windows!! And I can't get into Windows!

What I can do (ALL I can do) is run Ubuntu live from my USB. I've looked at lots of forums and I've tried several things, but nothing works! This is kind of a new issue so maybe nobody has had this problem yet. Others had the same error message, but from different problems. They can usually ONLY log into Windows. I can't get into Windows.

When I boot Ubuntu live from the USB I can look into the files for my Windows and Ubuntu installations, but I can't boot into either one.

Here's what I tried (which didn't work so far):

-re-installing ubuntu 12.10 -boot-repair program in Linux

Here's another piece of information. When I tried boot-repair, it told me that "The boot of your PC is in Legacy Mode... You may want to retry after changing it to EFI mode."

I don't know how to change it to EFI mode.

ALSO... boot-repair tells me to: "remember to tell the bios to boot on sdb1/EFI/ubuntu/grubfix64.efi"

I don't even know what that means.

If you're interested... I tried the boot-repair three times and got these URLs:

http://paste.ubuntu.com/1565228 http://paste.ubuntu.com/1565261 http://paste.ubuntu.com/1565303

Anyone with any info PLEASE help me out. My brand-new computer is unbootable...

marked as duplicate by Eliah Kagan, Eric Carvalho, Tom Brossman, Alvar, hhlp Jan 25 '13 at 10:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Boot-Repair solved my problem!

I can load Windows now!

But I had to access the BIOS first and switch from "Legacy" to "UEFI." Boot-Repair wouldn't work until I did that. I also seem to have benefited from restoring the MBR (also using boot-repair).

IF ANYBODY NEEDS TO KNOW HOW TO USE BOOT-REPAIR, here is the link (I used the code from the terminal to install it while running Ubuntu live from a usb:


To be clear: My urgent issue is solved (I couldn't login to ANY installed operating system). That's why I posted this. I still have the remaining problem of trying to properly install and boot Ubuntu, but that's actually a different issue. Right now my computer is usable again.

This is the link to the boot-repair file which salvaged my computer:


Thanks very much to everyone who contributed.

And jackfb: I will be using your wiki to fix my Ubuntu-install. Still can't load it because GRUB2 is on sdb7... gotta get it into sdb2...


From what I can tell, the UEFI bootloader of your computer is not even loading the partition on which GRUB is installed, so you never see GRUB at all. Take a look at this launchpad question regarding that message from boot-repair:

If you don't know which to choose, I would recommend the following:

1) first click "Yes", reboot and check if boot is repaired. (works when your computer is hybrid BIOS & EFI)

2) If still not good, that means that your computer absolutely needs a EFI partition. Please create a EFI partition , then run Boot-Repair again (optionally you can check in the Advanced options that your EFI partition is correctly detected).

Looking at your pasted code, I see the following:

 => No boot loader is installed in the MBR of /dev/sda.
 => No boot loader is installed in the MBR of /dev/sdb.
 => Windows 2000/XP/2003 is installed in the MBR of /dev/sdc.


sdb7: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  Grub2 (v1.99-2.00)
    Boot sector info:  Grub2 (v2.00) is installed in the boot sector of sdb7 
                       and looks at sector 288854272 of the same hard drive 
                       for core.img. core.img is at this location and looks 
                       in partition 1 for (,gpt7)/boot/grub.
    Operating System:  Ubuntu 12.10 
    Boot files:        /boot/grub/grub.cfg /etc/fstab

Your have GRUB installed on /dev/sdb7, but your motherboard has no reason to look there to begin booting. You have Windows' boot files on /dev/sdb:

sdb1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /EFI/Boot/bkpbootx64.efi /EFI/Boot/bootx64.efi 
                       /EFI/Boot/bootx64.efi.bkp /EFI/ubuntu/grubx64.efi 
                       /EFI/Dell/Boot/bootmgfw.efi /EFI/Dell/Boot/bootmgr.efi 
                       /EFI/Dell/Boot/bootx64.efi /EFI/Dell/Boot/memtest.efi 

With no errors, your computer should boot there. However, it seems it wants to boot from sda.

I would recommend removing the non-Windows hard drives, to see it the computer will boot. If it will, re-run your boot-repair and then try rebooting to get GRUB. Once that works, add in the other drives, one at a time. If after you add another drive the computer will not boot, you know it is prioritizing that drive for a bootloader (this should not happen, but it might).

  • I'm gleaning some information here.I will totally uninstall Ubuntu and delete the new partition, putting that memory back into the partition it was originally in. Even if I can just get back into Windows 8 then I can start from scratch. I'll try that tonight after work and then I'll get back to you. I'm using Ubuntu 12.10 which is supposed to include UEFI and secure-boot support. Also. yes, Windows 8 seems to be installed across a bunch of partitions! And when installing Ubuntu, it doesn't recognize that Windows is installed. Should I install Ubuntu in the same partition as Windows??? – Matt Payne Jan 24 '13 at 17:28
  • Thanks everyone for the answers so far. You're giving me hope! – Matt Payne Jan 24 '13 at 17:28

Another solution to your problem would be to enter the bios during bootup and to disable both UEFI and FAST BOOT and you should be able to boot into both Windows 8 and Ubuntu without any difficulties...

  • Windows 8 will refuse to boot with UEFI disabled. – Eliah Kagan Jan 24 '13 at 8:49
  • Can't get into bios during bootup... with the new UEFI system on new motherboards the window for pressing f2 is allegedly 0.02 seconds... super-fast bootup but less control over your computer, courtesy of Microsoft :( – Matt Payne Jan 24 '13 at 17:17
  • NEW UPDATE... I did manage to get into the BIOS screen (Huge benefit here!) I just kept pressing f2 really fast LoL... and it worked! I put it in UEFI mode instead of Legacy and kept "secure boot" turned OFF. Now it still won't load an operating system but it gives me a new message: "No Bootable Device Available." I'll play around with it more after work, but does anybody have further insight based on this new development? – Matt Payne Jan 24 '13 at 17:53

I got the same problems trying a triple boot W8/Ubuntu12.10/Mageia2 Eventually I managed setting this triple boot. Some remarks:

  1. Are you sure that your Ubuntu version is EFI compatible ? It should be (for W8)
  2. Is your Bios order correct ? Did you stop the secure boot unsupported by Ubuntu 12.10 64bit?
  3. You should use the W8 partition /boot/efi (partition sda2 created by W8) to store Ubuntu Grub2 ;don't create a new partition for it.
  4. Are you sure that W8 was installed on 1 partition ? Mine was installed on 6 partitions (netbook SAMSUNG 350V5C-S06FR)

If you want to install Ubuntu in EFI/GPT mode , have a look at my wiki http://doc.ubuntu-fr.org/multiboot%20ubuntu12%20windows8 You will be able to install EFI and non EFI OS on the same disk. Jackfb

  • Ubuntu 12.10 is UEFI compatible. Windows 8 DOES seem to be installed across several partitions. Should I install Ubuntu on the same partition as Windows? Is it possible to install Ubuntu on one partition and the GRUB2 on a separate one? I will look at your wiki. Thanks for your answers. – Matt Payne Jan 24 '13 at 17:30
  • Create one separate partition for Ubuntu (one is enough) .Grub2 must be installed on the W8 /boot/efi partition ; you will have to do it yourself ; see my wiki . – jackfb Jan 24 '13 at 17:41
  • Dual booting with Windows 8 preinstalled is a process long and precise : several ways to arrive at the result . But don't mix them together . – jackfb Jan 24 '13 at 17:52

You should reinstall Ubuntu instead of fixing your Ubuntu problems, it will be faster and safer.

Not the answer you're looking for? Browse other questions tagged or ask your own question.