How do I open the application launcher ("start menu") of Kubuntu with my Windows key? Similar to how the Start menu in Windows is opened. I don't want to use Alt+F1.

enter image description here


14 Answers 14


If you assign the launcher shortcut key to Meta+F1 or Alt+F1, KDE will instead interpret this as assigning it to solely the Meta key.

To open the settings window, right-click on the launcher icon and choose Configure Application Launcher. Then click on Keyboard shortcuts (as shown below).

After clicking Apply, the launcher should open when just pressing Meta. This currently works on Plasma 5.24 and 5.25.

Application Menu Settings window


About modifier keys

Modifier keys like Ctrl, Alt and also the Meta (also called "Super" or "Windows" key, are meant to operate only as modifier keys. This design works its way down to the roots of all the libraries under the GUI you see using KDE: Qt, Xorg, etc.

Your exact question is here on the KDE Forums by the way: Super key to load Application Menu.


It seems however, that there's a large audience for this feature. So, in case you really want this to work, you could try the ksuperkey package, which contains all you need:

ksuperkey allows you to open the application launcher in KDE Plasma < 5.8 using the Super key (also known as the "Windows key"). If you hold down the Super key it will still act as a modifier key, allowing you to use it for other keyboard shortcuts.

ksuperkey is a small application that runs in the background as a daemon. It was forked from xcape by Albin Olsson: https://github.com/alols/xcape

ksuperkey can be installed from this PPA.

Note that KDE Plasma 5.8 and above will support this feature by default.

  • 1
    Thank you very much! Wow it was soo easy with Ubuntu. I appreciate it!
    – sushi2141
    Jan 25, 2013 at 0:47
  • Is there a way to assign this to a hot corner, like in gnome-shell?
    – user267814
    Apr 11, 2014 at 11:56
  • 1
    @dan, you've edited my answer with the statement that it is now built-in in 5.8+, but how do we use it?
    – gertvdijk
    Mar 20, 2017 at 10:43
  • 1
    Nothing works on KDE Neon. By nothing, i mean that assigning your own shortcut never ever does anything. It's plain broken. Note that there's no shortcut by default because you will certainly have replaced the default weird menu with the alternate sane one. Feb 11, 2018 at 1:06
  • 4
    this is outdated. later plasma versions come with Meta key as default and let you restore it if lost by selecting Meta-F1 as indicated in the other answer
    – user47206
    Jan 16, 2019 at 9:24

It doesn't do exactly what you are asking for, but ALT-Space opens a search box with which you can launch basically the stuff you could select from the Application Launcher.

  • 2
    Was exactly what I was looking for and I didnt even know.
    – Vasspilka
    Oct 23, 2015 at 13:18
  • Such an underutilized feature IMO, from someone who's default action, is to strike the meta whenever launching an application. Apr 4, 2019 at 13:01
  • that's still 2 keys, for a super-common feature. Sep 27, 2020 at 9:43
  • Agreed, this answer does not perfectly answer the question, but ALT + SPACE works perfectly for my needs. Oct 12, 2022 at 17:06

Feature has been added by default since Plasma 5.8. If it's not working, make sure your "Start Menu" widget has a global shortcut like Alt+F1 set. You can't assign it directly to Meta, but it will open with Meta if another shortcut is assigned).

Right Click the KDE Icon → Application Menu Settings
Keyboard Shortcuts Tab → Shortcut: Alt+F1

Latte Dock:

If you're using Latte Dock, you will need to run the following commands mentioned in it's Wiki.

kwriteconfig5 --file ~/.config/kwinrc --group ModifierOnlyShortcuts --key Meta  "org.kde.lattedock,/Latte,org.kde.LatteDock,activateLauncherMenu"
qdbus org.kde.KWin /KWin reconfigure


  • 2
    Very nice. This is my experience. After upgrade things sstopped working. I had two places to set shortcut for launcher widget. Had to move from one to the other so that win key started to work again. My credit to superuser.com/q/1588474/111432 May 20, 2021 at 17:40
  • Thanks, I'm using Latte panel and this works well
    – a3k
    Jun 15, 2022 at 3:00

simple workaround without loosing meta: meta + z (u.s. layout)

can be hit with just one finger at one

  • Simple and effective!!!
    – Diosney
    Nov 5, 2015 at 22:12
  • I like this workaround since with ksuperkey there is a lag when closing the menu by tapping Super twice.
    – Diosney
    Nov 5, 2015 at 22:12
  • 1
    As of KDE Plasma 5.5.5, this doesn't work. Worse, if you press Meta+z in the terminal, you'll get some odd string. Aug 17, 2016 at 23:30

I'm on Plasma 5.8.5 and I can enable this feature by going to System Settings -> Input Devices -> Keyboard -> Advanced -> The third checkbox should be "Alt/Win key behavior" -> Choose "Meta is mapped to Win keys" -> Apply

You are all set :)

  • 12
    On my system (Kubuntu 18.04 LTS) there're two alternatives: Meta is mapped to Left Win and Meta is mapped to Win. I tried both, but neither of them worked.
    – code_dredd
    Sep 18, 2018 at 16:56
  • 1
    No effect for me... same result as code_dredd
    – Vince
    Sep 14, 2020 at 7:59
  • it worked for me Nov 3, 2022 at 21:10
kwriteconfig5 --file ~/.config/kwinrc --group ModifierOnlyShortcuts --key Meta "org.kde.plasmashell,/PlasmaShell,org.kde.PlasmaShell,activateLauncherMenu"

works most of the time for me. It adds the setting to the kwin config file. This means it defines a new so called "ModifierOnlyShortcurt", which is just the Meta key to activate the launcher menu.

  • 1
    This is the correct answer.
    – OneOfOne
    Jun 20, 2022 at 21:03

While the accepted answer may have worked a few years ago, ksuperkey does not seem to work on Kubuntu 15.10, when installed from PPA. I have no doubt ksuperkey is a better solution, but I ended up following the link in gertvdjik's answer and using this solution, which works absolutely fine. Posting here for future googlers who had the same trouble as I did.

For brevity;

NOTICE: YOU WILL LOSE THE META KEY - so you might want to map it somewhere else.

Run xev | grep keycode press the meta key and watch the output (the code is likely 115)

then add an entry to your Xmodmap configuration:

echo 'keycode 115 = F13' > ~/.Xmodmap

"xmodmap ~/.Xmodmap" will change the keysym to F13 (not present on most keyboards ;-) and you can use it like any regular key.

If your distro does (probably) not invoke ~/.Xmodmap by default, add a short script to ~/.kde/share/autostart/xmodmap.sh

#!/bin/sh xmodmap $HOME/.Xmodmap

and make it executable chmod +x ~/.kde/share/autostart/xmodmap.sh

  • I receive this error : cat: keycode 115 = F13: No such file or directory
    – Sadegh
    Feb 4, 2016 at 12:25
  • @Woeistg You might try replacing that line with echo "keycode 115 = F13" >> ~/.Xmodmap, the important thing is that the ~/.Xmodmap file contain that line. If that works for you i can edit the post.
    – Knetic
    Feb 4, 2016 at 19:09
  • Note: ksuperkey works on Plasma 5.7, built from source (KDE Neon with Ubuntu 16.04 base)
    – sola
    Jul 17, 2016 at 9:31

For me, the keyboard shortcut Windows + Enter worked (Kubuntu: 22.04/KDE Plasma: 5.24.6).


  1. Right click on Application Launcher icon, select Configure Application Launcher.

enter image description here

  1. Go to Keyboard Shortcuts tab and click on Input ... button.

enter image description here

  1. Hit Windows + Enter keys on the keyboard.

(Windows = Meta = Super = same key.

Enter = Return = same key)

  1. It should look like this

enter image description here

  1. Finally, click on Ok to save the configuration and test.
  • 1
    Finally a solution that works. Thank you!
    – Jeff Lamb
    Apr 25 at 18:20

This soultion worked for me

sudo apt-get install git gcc make libx11-dev libxtst-dev pkg-config
git clone https://github.com/hanschen/ksuperkey.git
cd ksuperkey

then make it to start every-time your computer boots up.


  • Doesn't work on Kubuntu 19.04 anymore
    – Dakkaron
    Mar 31, 2022 at 11:54

Running the "If you wish to revert..." commands from here fixed it for me in the latest Kubuntu after I 'broke' it switching to a custom doc.

  • it didn't work for me.
    – SalahAdDin
    Apr 7, 2022 at 15:55

This simple solution don't use the Meta key but you can use only the Menu key for the shortcut.

The Menu key

  • doesn't work on my laptop
    – user47206
    Jan 16, 2019 at 9:08
  • We have 2020 now, it should be possible to use the meta key.
    – shuhalo
    Sep 2, 2020 at 7:28

I have also be confused about this question weeks ago.
Today I added a panel and a Tiled Menu on it. Then I use alt+F5 to activate it.
Beacuse alt+F1 F2 F3 F4 are alreadly occupied. Really, not alt+F1.
It happened just after reboot that the Super was back to life!
So I think that:

The one on Latte Dock won't work.
The one on a default panel will do.

It's interesting.
KDE Plasma Version:5.14.5
KDE Frameworks Version:5.54.0
Debian 10.3


It just randomly stopped working today for me. Had to right click the Application Launcher (start menu) > Configure > Assign a new keyboard shortcut 'Meta + Z' because some ditzy person decided to disable the option to just use Meta (That I can assure you was deliberate) Then. Boom! It started working with just Meta and also Meta + Z.

What a silly solution all because KDE has dementia and can't remember what happened 5 minutes ago. History in Konsole, Screen layouts, etc etc. There are many such examples.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .