3

I have a 4 Gig USB drive that I'd like to format.

I go to the Disk Utility, and try to format it, but it says that the device is busy. (This same error occurs no matter whether I tried to format the whole drive, or just the partition.)

So, I do some research, and figured out how to disable automount. It's now disabled.

To be on the safe side, I first unplug then reconnect the USB stick then tried:

sudo umount /dev/sdb
sudo umount /dev/sdb1
sudo umount /dev/sdb*

Now, the Disk Utility STILL gives me the same error - usually "/dev/sdb is busy" or "/dev/sdb1 is mounted" or similar.

  • 3
    Why don't you use GParted which will allow you to unmount from the context menu and do whatever you want to do (chech, format, label, etc.) easily? – Sadi Jan 24 '13 at 12:30
  • 1
    Oh, man, I forgot about GParted. I had that a while back, I loved it. After I had to reinstall Ubuntu, I sort of forgot about it... Thanks for reminding me about that! I actually figured out the problem, though: I'd left the Startup Disk Creator open, and for some reason, it was auto-mounting my flash drive... – JamesTheAwesomeDude Jan 24 '13 at 14:37
1

Run df -h in terminal and make sure there is nothing mounted that looks like /dev/sdb*. I had /dev/sdb11/ and /dev/sdb8 mounted so I had to run umount /dev/sdb11 and umount /dev/sdb8.

1

In my case the disk was umounted and the problem persisted. I had to use gparted to delete the partition, restart (as requested by the app) and try to format it again. After that I was able to.

  • In my case even "delete partition" option was unavailable. I had to format to "cleared" with GParted and than I was able to create new partition table. – kurp May 3 '19 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.