I have been following the same tutorial that everyone else is referencing. My fstab entry is exactly like in the tutorial with changes to actual location. I keep getting the error

mount: only root can mount //freenas/Server on /media/Server

This is the most irritating thing I run into time and time again with running Ubuntu. I have had a freeNAS box with a single hard drive in it for almost 4 years. I had my server mounted correctly a month ago but I started from scratch again.

The server is functioning normally as I have another Ubuntu box running XBMC perfectly fine.

I am running Ubuntu 12.10 but get the same message with 12.04.

I have installed cifs-utils and smbnetfs from terminal after installing samba from the software center. This is how I got it running last time.

The workgroup in samba matches my network workgroup.

I don't have any credentials to check with the share as it is setup as guest.

I can't browse the network as it keeps giving me a timeout error. I also can't open my share from Nautilus by hitting Ctrl+L and manually typing my server share (//freenas/Server).

Edit 1: I'm able to browse my network but still am getting the error message?

Edit 2: I'm able to mount the share after testing the individual options one my one. It seems that using codepage=unicode was causing the problem. My fstab entry now looks like:

//freenas/Media /home/charles/Server cifs guest,iocharset=utf8,uid=1000 0 0

Edit 3: I can only mount using only "guest" for options? Last time I ran into an issue of not being able to open files on other computers that originated from my Ubuntu machine?

Last Edit: I had to force my freeNAS server(Version: to have the same permissions as Ubuntu, GID=1000 for uid=1000. Also freeNAS by default creates a guest user account ftp with a null password. With these three items and adding my freeNAS IP address to /etc/hosts I'm up and running. Sorry for the super long delay closing this question but I greatly appreciate the help!

fstab entry: //freenas/Media /home/charles/Server cifs username=ftp,password=,uid=1000 0 0

  • Start by actually showing the line you are using to mount the share with fstab and the output of ls -l in /media. – Bruno Pereira Jan 23 '13 at 23:42
  • //freenas/Media /media/Server cifs guest,uid=1000,iocharset=utf8,codepage=unicode,unicode 0 0 – charels88 Jan 26 '13 at 22:58
  • I have tried making the folder "Server" with sudo mkdir or browsing through nautilus and manually creating the folder. I have tried mounting is /media, /mnt, and even /home/USER/. I was able to mount my freenas share to my /home/USER/ after manually creating the folder via nautilus before I started fresh. – charels88 Jan 26 '13 at 23:02
  • In your edit 2, is uid1000 a typo here or a typo in your actual fstab? It should be uid=1000. – John Siu Feb 5 '13 at 15:22
  • It was just a typo here John I will fix it, Thanks. – charels88 Feb 10 '13 at 20:38

I think your box is having difficulty resolving the IP of freenas via wins/netbios. Sometimes it is very difficult to resolve.

  1. In your /etc/fstab, use ip address instead of hostname like following

  2. In your /etc/hosts, add following line    freenas
  3. /etc/fstab, use credential

     //freenas/Media /home/charles/Server cifs defaults,uid=1000,username=<user>,password=<pass> 0 0
  • I'm out of town but will try this when I get back. – charels88 Jan 26 '13 at 23:03
  • I have tried both options John but have had no success. From a stroke of luck I'm able to now browse my network and can see and use my server. Any other suggestions to auto-mount the share? – charels88 Feb 1 '13 at 1:54
  • If you are trying to mount from Nautilus, maybe try comment/remove the line from /etc/fstab. – John Siu Feb 4 '13 at 18:53
  • I'm trying to auto-mount using fstab but can mount only if I have "guest" for options – charels88 Feb 5 '13 at 0:22
  • Did you setup your freenas with guest only access? Or you want to connect with credential? Check (3). – John Siu Feb 5 '13 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.