I have a Ubuntu 12.04 Desktop which uses a network proxy.

I have created a Virtual Host:

<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName dev.my-example.com

DocumentRoot /home/user/Projects/my-example
<Directory />
    Options FollowSymLinks
    AllowOverride All
<Directory /home/user/Projects/my-example/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride All
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all

ErrorLog ${APACHE_LOG_DIR}/myex.error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/myex.access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
    Allow from ::1/128


I did sudo a2ensite <VirtualHostFile> and then sudo service apache2 restart

I have added dev.my-example.com to /etc/hosts:   localhost dev.my-example.com

And yes, there are files in the document root. (Yii framework's initial file system. The permissions are all correct.)

I can ping the domain:

$ ping -c4 dev.my-example.com
PING localhost ( 56(84) bytes of data.
64 bytes from localhost ( icmp_req=1 ttl=64 time=0.020 ms
64 bytes from localhost ( icmp_req=2 ttl=64 time=0.013 ms
64 bytes from localhost ( icmp_req=3 ttl=64 time=0.013 ms
64 bytes from localhost ( icmp_req=4 ttl=64 time=0.012 ms

Using dconf-editor, I added dev.my-example.com to the system -> proxy -> ignore-hosts setting: ignore-hosts ['localhost','','my-example.com']

When I try to bring up the URL in Firefox, I get the following error:

Network Error (dns_server_failure)

Your request could not be processed because an error occurred contacting the DNS server.
The DNS server may be temporarily unavailable, or there could be a network problem.

The problem is that the browser is (somehow) NOT ignoring the proxy server for this domain. But it does ignore DNS for, say "http://localhost/phpmyadmin".

What am I missing?



The problem wasn't with Ubuntu 12.04; you have to ensure that Firefox retrieves the proxy settings correctly:

  1. Go to: Edit -> Preferences -> Advanced (tab).
  2. Under Connection, where it reads "Configure how Firefox connects to the Internet", click on the Settings button.
  3. Click on "Manual proxy configuration".
  4. Add the domain and port for your proxy.
  5. Check off "Use this proxy server for all protocols" (This is the correct setting for my network; it is possible that you network uses different proxies for https, FTP, and/or SOCKS. YMMV)
  6. Click on the "OK" button.

(I must remember to test with other browsers; rekonq worked out-of-the-box...)

  • hi Kevin. You do not need to put (solved) in the title of your question. Just below the up and down arrows on the side of your answer, you can mark it as solved. – don.joey Jan 25 '13 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.