At work we have to use Sonicwall Netextender to connect over VPN. The NetExtender client works fine on Windows x64 for me, but when using the same settings in my Ubuntu , the connection seems to work fine at first - But after just some packages have been sent, it slows down to almost 0 or 0 ( the connection is still up and seems fine)

Some other people at work have the same NetExtender problem with their Ubuntusetups, so we belive it's some failure with the NetExtenderclient - or that some workaround is needed with it.

So the Question is: Has anyone had success in using NetExtender on Ubuntu 12.x, and what specific settings did you use?

Also - are there any Open Source alternative NetExtender clients we could use instead of the SonicWalls one?

BTW (I tried stuff like this http://www.webantix.net/2012/02/sonicwall-netextender-on-ubuntu-x64.html)

Also tried with latest NetExtenderPackage "NetExtender.Linux.7.0.741.x86_64" and it's the same symptoms - i can connect successfully, fetch about one webpage, and then everything just seem to stall. I also upgraded to Ubuntu 13.04.

Irritating that it works flawlessly on the same machine with Windows 7 in dualboot, same settings.


See Franck Routiers Post:

Note, you'll have to have the Java Development Kit installed on your System.

1) go to https://sslvpn.demo.sonicwall.com/cgi-bin/welcome

2) log in with demo/password

3) click on NetExtender icon, this will download a tar.gz with the client

4) sudo ln -s /lib/x86_64-linux-gnu/libssl.so.1.0.0 /usr/lib/libssl.so.6

5) sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.6

6) un-tar the client, make install script executable and launch install

You're done.

Connect with :

sudo netExtender -u user -p password -d domain server

(and see man netExtender)

  • Sorry, no that won't work for me or my colleagues, it's the same solution as describe in the link in my question. – Beamie May 18 '13 at 7:55
  • 4
    Mine works without the ln -s steps 4 & 5 in Ubuntu 14.04. Very easy. – Ubuntuser Oct 17 '14 at 1:56
  • 1
    It needs a Java JDK installed to work. – Jrgns Jan 26 '15 at 5:50

Not sure if you got a solution to this or not, but Dell Sonicwall just released a firmware update to the NSA series that somewhat addresses this type of issue. I was having similar "trailing off" issues with my windows client. The Global VPN client would work fine, but the Netexender would slow to a crawl after a couple minutes. This firmware update has increased the throughput by a factor of at least eight and the speed stays constant!

  • Oh, wish I could test, however I changed work since this.. Thanks anyhow, and hope your answer helps someone. – Beamie Jul 18 '14 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.