I was installing mongo DB on my Ubuntu-12.04 system, but while i give the following command in my terminal

apt-key adv --keyserver keyserver.ubuntu.com --recv 7F0CEB10

It gives me the following error

gpg: requesting key 7F0CEB10 from hkp server keyserver.ubuntu.com
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

Is there any other way of installing mongo db or what can be done to avoid the above situation?

5 Answers 5


The command that is failing is the one that installs the key that is used to sign the MongoDB packages, so that apt-get can determine whether the packages are genuine.

You could try skipping installation of the key and adding --allow-unauthenticated when you run apt-get to install the packages. See How do I bypass/ignore the gpg signature checks of apt? for more detail.

But ideally, you need to figure out why you cannot connect to the key server to install the key.

Firstly, you can check your Internet connection and DNS by visiting http://keyserver.ubuntu.com/ in a browser. If your Internet connection is working you will see a simple page entitled SKS OpenPGP Public Key Server. This shows that your computer can look up and connect to the key server.

If this is the case, then it is likely that the problem is a firewall or proxy server restricting your access to the specific port that apt-key wants to connect to. See No gpg key from behind a firewall for details for how to allow apt-key to connect via a proxy server.


The problem was with proxy, blocking connection to keyserver, add http-proxy details in the apt-key command itself.

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --keyserver-options http-proxy=http://username:password@proxy:port --recv-keys KEYID

I have also mongodb installed in my system and I take the help from this site http://www.mkyong.com/mongodb/how-to-install-mongodb-on-ubuntu/

And it always works.


Try this command

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 7F0CEB10

otherwise use this package to install instead



Simple Mongo Setup on AWS Ubuntu 14.0

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 7F0CEB10

echo 'deb http://downloads-distro.mongodb.org/repo/ubuntu-upstart dist 10gen' | sudo tee /etc/apt/sources.list.d/mongodb.list

sudo apt-get update
sudo apt-get install -y mongodb-org
sudo apt-get install php5
sudo apt-get install apache2
sudo apt-get install libsasl2-dev
sudo apt-get install php-pear php5-dev
sudo pecl install mongo

Add the lines below in /etc/php5/apache2/php.ini:

extension_dir = "/usr/lib/php5/20121212"

Then restart apache:

sudo service apache2 restart

Create a php file in /var/www/html, with these contents:


Run the file in a browser and find the Extension "Mongo".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .