1

I am running 12.04 (precise) Ubuntu on my computer, which I keep it up to date. Recently skype started being listed as a "kept back" package whenever I ran a software update.

Stupidly I uninstalled Skype manually using "apt-get purge" intending to then install the most recent version. I have learned never again to do this, as now I am unable to reinstall any version of Skype. This really is a problem since it is my prime way of keeping in touch with faraway relatives.

I tried telling apt-get to specifically install the version of skype and skype-bin currently in precise-updates (4.1.0.20.0-0ubuntu0.12.04.2) and which I had working just fine on my computer, but it fails:

# apt-get install skype=4.1.0.20.0-0ubuntu0.12.04.2
The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.


# apt-get install skype-bin=4.1.0.20.0-0ubuntu0.12.04.2
The following packages have unmet dependencies:
skype-bin:i386 : Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Running aptitude search skype, I get:

pi  skype                                                              - client for Skype VOIP and instant messaging service
p   skype:i386                                                         - client for Skype VOIP and instant messaging service 
v   skype-bin                                                          -  
pB  skype-bin:i386                                                     - client for Skype VOIP and instant messaging service - binary files  

I have learned from the man page how to interpret those initial letters and it seems weird: skype is not installed but the "stored action" is to install it. And skype-bin is listed as uninstalled and broken.

UPDATE: As suggested by Tumbleweed, here is the output of running apt-cache policy:

# apt-cache policy libqtwebkit4:i386 skype
libqtwebkit4:i386:
 Installed: (none)
 Candidate: 2.2.1-1ubuntu4
 Version table:
  2.2.1-1ubuntu4 0
   50 http://us.archive.ubuntu.com/ubuntu precise/main i386 Packages
skype:
 Installed: (none)
 Candidate: 4.1.0.20.0-0ubuntu0.12.04.2
 Version table:
  4.1.0.20.0-0ubuntu0.12.04.2 0
   500 http://archive.canonical.com/ubuntu/ precise/partner amd64 Packages

UPDATE: After this I manually installed libqtwebkit4 using apt-get install, but that version (2.2.1-1ubuntu4) did not satisfy the dependencies of skype-bin (">= 2.2~2011week36").

Any advice on how to fix this mess would be dearly appreciated! I promise I have learned my lesson never to try to force any update whatsoever...

  • Can you include the output of apt-cache policy libqtwebkit4:i386 skype? – tumbleweed Jan 22 '13 at 13:46
  • @tumbleweed, thank you for looking at this. I have added the output of apt-cache policy to the body of the question above. – Sonia Bastclurd Jan 22 '13 at 17:31
  • @tumbleweed, I have fixed the output of apt-cache policy and also installed libqtwebkit4, but the latter did not fix anything as apparently this is not the right version. – Sonia Bastclurd Jan 22 '13 at 21:52
  • Hrm, it should. 2.2.1 > 2.2~ (~ is special in debian versions). Try an apt-get install libqtwebkit4:i386? – tumbleweed Jan 23 '13 at 11:51
  • @tumbleweed, running "apt-cache policy ibqtwebkit4" now shows version 2.2.1-1ubuntu4 installed. But installing skype (or skype-bin) keeps complaining of an unmet dependency: "skype-bin:i386 : Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed". What can I do? – Sonia Bastclurd Jan 23 '13 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.