I recently set up an old desktop with ubuntu sever 12.04 32 bit. After finishing the installation and logging into the server, I tried to access it from other computers (both windows and ubuntu) on the network, but I couldn't see it anywhere. Any help?


4 Answers 4


Important: as hudolejev suggests, seeing is different from logging in.
If you can ping the server but not ssh into it, then make sure you
have installed the SSH server (run sudo apt-get install ssh) and start it:

sudo service ssh start

If you can't ping the server, follow the steps below to diagnose the problem:

You have to move along! First of all, check it's connected to the network.

Run ifconfig to check that a network card is detected and configured correctly.
You should see an ethX card with an IP and UP, something like that:

eth0      Link encap:Ethernet  HWaddr 00:17:1a:bd:b6:3c  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::216:36ff:febd:b64b/64 Scope:Link
          RX packets:380931 errors:0 dropped:0 overruns:0 frame:0
          TX packets:488362 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:53036441 (53.0 MB)  TX bytes:522204820 (522.2 MB)
          Interrupt:18 Memory:da000000-da020000 

Try to ping that IP from the other computers and your server itself.
Then, try to ping the router (run route -n to see its address).

Also check that you don't have the IPTables firewall activated by running:

iptables -F
iptables -X
iptables -t nat -F
iptables -t nat -X
iptables -t mangle -F
iptables -t mangle -X
iptables -P INPUT ACCEPT

Use tcpdump or Wireshark to see if the traffic really reaches the server.
When really desperate, cat /var/log/{syslog,dmesg,kern.log} | tail -n 200 and
look for some handy message from the kernel.

If it still doesn't work, then repeat this procedure with the other
computers. That seems more like a general network administration
problem, rather than Ubuntu's; you can get better help on that
subject at SuperUser.

  • Part of what we do on AU is solve Layer 8 problems. It's not nice to tell OP it's their fault.
    – camconn
    Jan 21, 2013 at 18:54
  • But IMHO if Ubuntu is configured correctly (it probably is, if he just did a fresh install and these steps succeded) then it's better to take this to a specialized site, like SuperUser (where it'll get more attention). Editing to clarify. Jan 21, 2013 at 18:58

I tried to access it

How? SSH? Telnet? HTTP?

Is SSH daemon running on server?

ps ax | grep sshd

If not, sudo apt-get install openssh-server.


Try rebooting. I had this exact same issue. It seems app armor gets hung up on if you make a change to the eth0, it really wants to block the static IP as its looking for it to be DHCP. Just make sure you double check the config in /etc/network/interfaces.


In Linux machine check /etc/samba/smb.conf. If you have in your shares option browseable = no, this means that you can mount the share but you can't see it on your network ,it's like invisible share. You'll need to edit these.

Restart Samba for it to take effect:

sudo service smbd restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.