When I use GNOME Shell, and GNOME Connection Manager program, and try Alt+S in Midnight Commander (all inside GNOME Connection Manager), I get a window context menu opened, instead of the search action shortcut in MC. This is just an example: it's an issue in other programs too.

I cannot fix this with keyboard shortcuts settings as described in this Ask Ubuntu answer. There is no such menu item as Keyboard Shortcuts.

Also using the trick with the Escape key is not good, as it's a workaround rather than a real solution.

How can I simply disable this particular Alt key behaviour?

  • "Edit > Keyboard Shortcuts" is a menu item of gnome terminal. Have you look in "Settings -> Shortcuts" of Gnome Connection Manager? - I don't have it installed, so I can't check. – Pavel A Jan 24 '13 at 9:51
  • For Midnight Commander use Ctrl+S for the quick search instead. – whtyger Jan 25 '13 at 10:45

GNOME Connection Manager is intercepting the Alt key combinations for its own menu and refuses to pass it on to the shell it is hosting (where your MC instance is running). This is not configurable.

This is a bug in GNOME Connection Manager, or to be precise in the GUI library it uses (Gtk), so the only good solution is to go to their site and report the bug.

The other approach is filing a bug with GTK about "Alt being hardcoded" but you will need a lot of charisma and endurance to convince them to make Alt configurable. All alternatives will be workarounds, of which the ESC-key trick is the most elegant.

  • 1
    Yes, not even Autokey can catch these combinations to enable some fixing. This is really bad. I reported this as a bug, if anyone wants to join the shout-out. – metakermit May 18 '13 at 13:59

There is a workaround which actually works. (tested on Ubuntu 15.10 and Gnome Connection Manager v1.1.0)

For me, main problem was with Alt+F which I use very often, but in GCM it shows File menu.

My solution is to modify language file (en_US.po) and remove all menu mnemonics (eg. _File to File_).

cd /usr/share/gnome-connection-manager/lang
sudo sed -i -e 's/"_File"/"File_"/g' -e 's/"_Edit"/"Edit_"/g' -e 's/"_View"/"View_"/g' -e 's/"_Servers"/"Servers_"/g'  -e 's/"_Help"/"Help_"/g' en_US.po
msgcat en_US.po | sudo msgfmt -o en/LC_MESSAGES/gcm-lang.mo -

It will remove all menu shortcuts: Alt+F, Alt+E, Alt+V, Alt+S, Alt+H.

Gnome Connection Manager has also one more hard-coded shortcut: Alt+A (opens "Add host" dialog). You can disable it as well in the gnome-connection-manager.glade file:

cd /usr/share/gnome-connection-manager/
sudo sed -i 's/(<accelerator key="a" modifiers="GDK_MOD1_MASK" signal="clicked"\/>)/<!-- \1 -->/g' gnome-connection-manager.glade

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.