I'm running a fresh installed Ubuntu 12.04 LTS with ext4 on a SSD 520 by Intel. My mainboard is an ASUS Crosshair (latest BIOS 1207) with a Sil 3132 SATA Controller which claims to support SATAII. I have TRIM enabled. But my results are pretty bad in comparison to what could be expected:

sudo hdparm -Tt /dev/sda

 Timing cached reads:   2510 MB in  2.00 seconds = 1255.51 MB/sec
 Timing buffered disk reads: 376 MB in  3.00 seconds = 125.21 MB/sec

Is my mainboard bottlenecking it? Here are some info about the SSD in use:

sudo hdparm -I /dev/sda

ATA device, with non-removable media
    Model Number:       INTEL SSDSC2CW120A3                   
    Serial Number:      CVCV227301JE120BGN  
    Firmware Revision:  400i    
    Transport:          Serial, ATA8-AST, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6, SATA Rev 3.0
    Used: unknown (minor revision code 0x0110) 
    Supported: 9 8 7 6 5 
    Likely used: 9
    Logical     max current
    cylinders   16383   16383
    heads       16  16
    sectors/track   63  63
    CHS current addressable sectors:   16514064
    LBA    user addressable sectors:  234441648
    LBA48  user addressable sectors:  234441648
    Logical  Sector size:                   512 bytes
    Physical Sector size:                   512 bytes
    Logical Sector-0 offset:                  0 bytes
    device size with M = 1024*1024:      114473 MBytes
    device size with M = 1000*1000:      120034 MBytes (120 GB)
    cache/buffer size  = unknown
    Nominal Media Rotation Rate: Solid State Device
    LBA, IORDY(can be disabled)
    Queue depth: 32
    Standby timer values: spec'd by Standard, no device specific minimum
    R/W multiple sector transfer: Max = 16  Current = 1
    Advanced power management level: 254
    DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
         Cycle time: min=120ns recommended=120ns
    PIO: pio0 pio1 pio2 pio3 pio4 
         Cycle time: no flow control=120ns  IORDY flow control=120ns
    Enabled Supported:
       *    SMART feature set
            Security Mode feature set
       *    Power Management feature set
       *    Write cache
       *    Host Protected Area feature set
       *    WRITE_BUFFER command
       *    READ_BUFFER command
       *    NOP cmd
       *    Advanced Power Management feature set
            Power-Up In Standby feature set
       *    SET_FEATURES required to spinup after power up
       *    48-bit Address feature set
       *    Mandatory FLUSH_CACHE
       *    FLUSH_CACHE_EXT
       *    SMART error logging
       *    SMART self-test
       *    General Purpose Logging feature set
       *    64-bit World wide name
       *    IDLE_IMMEDIATE with UNLOAD
       *    WRITE_UNCORRECTABLE_EXT command
       *    {READ,WRITE}_DMA_EXT_GPL commands
       *    Segmented DOWNLOAD_MICROCODE
       *    Gen1 signaling speed (1.5Gb/s)
       *    Gen2 signaling speed (3.0Gb/s)
       *    Native Command Queueing (NCQ)
       *    Host-initiated interface power management
       *    Phy event counters
       *    unknown 76[14]
            DMA Setup Auto-Activate optimization
            Device-initiated interface power management
       *    Software settings preservation
       *    SMART Command Transport (SCT) feature set
       *    SCT Data Tables (AC5)
       *    Data Set Management TRIM supported (limit 1 block)
       *    Deterministic read data after TRIM
    Master password revision code = 65534
    not enabled
    not locked
    not frozen
    not expired: security count
        supported: enhanced erase
Logical Unit WWN Device Identifier: 5001517bb29a74d4
    NAA     : 5
    IEEE OUI    : 001517
    Unique ID   : bb29a74d4
Checksum: correct
  • "Sil 3132 SATA Controller" <-- Is this the only controller on the mainboard? This controller is known to be slow. You should have another controller too, I guess? – gertvdijk Jan 21 '13 at 11:11
  • Oh and please link to the exact mainboard you have there, as there appear to be many Asus Crosshair boards (it's a whole family). – gertvdijk Jan 21 '13 at 11:19
  • I am not completely sure about my mainboard, but it should be the first of its family: asus.com/ROG/CROSSHAIR After a closer look, I can confirm that besides the above mentioned RAID Controller I have 3 MCP55 SATA Controller onboard. – Til Hund Jan 21 '13 at 14:28
  • Then it does have two storage controllers: "NVIDIA nForce 590 SLI MCP" and "Silicon Image® 3132 SATA controller" as per the specifications. – gertvdijk Jan 21 '13 at 14:30
  • Is this NVIDIA nForce 590 SLI MCP true SATAII as advertised by ASUS and even discribed on Wikipedia: en.wikipedia.org/wiki/NForce_500#nForce_590_SLI_MCP? – Til Hund Jan 21 '13 at 14:35

In relation to the SSD, I also have an Intel 520 Series SSD Drive. Mine is the 120GB one. I ran the test as you mentioned and this is the result:

enter image description here

Although this is a test using 13.04, 2 weeks ago I was using it on 12.04 and it gave almost the same result (About ~40 MB less on the buffered disk reads but still high enough)

The only thing left here would be the motherboard. In my case I have the Intel DZ68DB with the latest firmware update. If I were to help in any way, I would first recommend:

  • At the end it was my motherboard's SATA Chip which is too slow. I bought myself a ASUS U3S6 PCI Card to bypass the issue for a while instead of buying a new motherboard, cpu and RAM. – Til Hund May 17 '13 at 17:24

Speed test with hdparm (get/set ATA/SATA drive parameters under Linux)

# hdparm -Tt /dev/sda


Timing cached reads: 4476 MB in 1.99 seconds = 2244.15 MB/sec
Timing buffered disk reads: 714 MB in 3.00 seconds = 237.77 MB/sec

Disk I/O test

# dd if=/dev/zero of=test bs=64k count=16k conv=fdatasync


16384+0 records in
16384+0 records out
1073741824 bytes (1.1 GB) copied, 4.69718 s, 229 MB/s

This is an intel 520 ssd 180 gb on dell 1121 http://namhuy.net/1541/intel-520-ssd-180gb-dell-1121-ubuntu.html


Random write performance for SSD hugely depends on write-caching inside device.

Check performance with two different options:

hdparm -W 0 /dev/sdX  # disable write cache
hdparm -W 1 /dev/sdX  # enable write cache

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.