I have UEFI based computer (I dont know the UEFI in detail but I guess it is a replacement of BIOS). In the Grub2 boot list there are 3 different Windows entry but none Ubuntu 12.10 entry. I m booting ubuntu by using grub console. I tried to use boot-repair program. When it starts it gives an warning EFI detected. Please check the options.. Then I ignore the warning and choose the Recommended Repair option. However it did not work too. Still no entry on boot list. I tried to use Windows bootloader to deal with the problem by using EASYbcd program but after I add ubuntu entry, windows bootloader failed too and I cannot boot windows now on. I guess my all settings amiss about EFI system. Do I need to do something special to grub with respect to the EFI? What is special about EFI and how can I solve the problem on GRUB?

Here all my grub information generated by BootRepair http://paste.ubuntu.com/1552273/

After now, I am getting an error from BootRepair:

An error occurred during the repair.

Please write on a paper the following URL:

In case you still experience boot problem, indicate this URL to:
[email protected] 

You can now reboot your computer.
Please do not forget to make your BIOS boot on sda4/EFI/ubuntu/grubx64.efi file!

The boot files of [The OS now in use - Ubuntu 12.10] are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot/efi partition (FAT32, 100MB~250MB, start of the disk, boot flag). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot/efi partition:] option of [Boot Repair].

My PC specs:

x64 Ubuntu 12.10
Asus K55V notebook
Windows 8 Installed on another partition (Currenty not bootable)
  • Only x64 version of ubuntu support UEFI. What version do you installed (x86 or x64)
    – leorize
    Jan 20, 2013 at 15:05
  • At the grub prompt, please type ls -l and indicate its output.
    – LovinBuntu
    Jan 21, 2013 at 23:30

1 Answer 1


It looks like you've got both BIOS-mode and EFI-mode installations of GRUB on your disk. If I had to guess, I'd say that you installed Ubuntu in EFI mode but it didn't quite work for some reason, and then you booted the Boot Repair tool in BIOS mode and it got a little confused and installed a BIOS-mode GRUB; however, it could be that they installed in the opposite order.

In any event, you should probably do what the error message suggested:

Please write on a paper the following URL:

In case you still experience boot problem, indicate this URL to:
[email protected]

Beyond that, you could try downloading the CD or USB flash drive image of my rEFInd boot manager and write it to a disk. It's possible, but far from certain, that it will get Windows and/or Ubuntu booting from rEFInd. If you have luck with it, you can then work from there on a longer-term recovery. To boot Ubuntu, you'll need to:

  1. Launch rEFInd
  2. Highlight one of the Linux kernel options (to boot vmlinuz-{something})
  3. Hit F2 or Insert twice to open the kernel options editor
  4. Add ro root=/dev/sda1 to the options
  5. Press enter

If this works, you can run the install.sh script to install rEFInd on your hard disk. I'm far from certain this will work, but it's worth a try....

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .