When I try to play a track on Jamendo.com, it does not work in chromium. In Firefox it does. The player seems not to use flash, but I'm not sure (I have no Web-dev experience). Anyway, Flash is installed and works in Firefox and Chromium. I even reinstalled (purged and installed) Flash to be sure.

What exactly happens: I click on the play button beside a track or in the player. The play icon changes to a pause button for not even a second, then changes back to a play button. Nothing happens, no sound or something. I have this problem since autumn or so. I think I had it on another website once, but I don't remember it.

At first I thought it's something with HTML5, because the front end of the web player seems not to be flash. But the soundcloud web player also has a non flash front end, but it works for me. So I have this problem currently only on Jamendo using chromium.

OS: Ubuntu 12.10
Chromium-Version: 23.0.1271.97 (Entwickler-Build 23.0.1271.97-0ubuntu0.12.10.1)
Blockers: Ad Block Plus (diabling it does not help)

I tried disabling all plugins but it did not help. I noticed something though: I am accepting all cookies and data, but when I'm on Jamendo or askubuntu or Youtube, there shows a cookie icon in the address bar that indicates that the Website is allowed to set cookies (according to my settings everyone is), but it was unable to set some of them. Cookie settings (german, sorry). Strange cookie indicator.
I'm not sure whether this has to say something though, since youtube and askubuntu and soundcloud work fine.

Can you tell me why it does not work, how I can fix it? And whats the technical difference to soundcloud causing it to work? Thanks.

  • Please mention your OS and its version. Please mention the browser versions. Please state whether you have installed some sort of ad or script blocker in Chromium. I can listen to this track using Chrome 24 (not Chromium) with all plug-ins disabled. So, IMO, it's nothing to do with Flash. I'll also mention that I don't have any sort of Java/OpenJDK installed. I don't know about the difference between the players of Jamendo and "soundcloud" but I suspect it isn't relevant to your issue. – user25656 Jan 20 '13 at 3:18
  • I added version numbers into the question. I also noticed some weird cookie-thing, I added this also. Disabling all extensions did not help. With Plug-ins you meant the extensions, did you? Because there was nothing like a flash extension shown. – verpfeilt Jan 20 '13 at 15:28
  • By plug-ins I mean what you see in chrome://plugins. I disabled all plugins and still could hear Jamendo. So Flash isn't needed, IMO. The image you provided re. cookies indicates that cookies are being blocked (because of the little red "x"). I suggest you check chrome://settings/content and make sure you aren't blocking any cookies at least you sort this issue out. – user25656 Jan 20 '13 at 15:59
  • chrome://settings/content leads to my first screenshot. As you can see all cookies are allowed. It says: "Allow local data storage (recommended)". I also disabled all plug-ins now from chrome://plugins, doesn't change anything. I think I'll try to purge chromium and install it again. – verpfeilt Jan 20 '13 at 19:54

I solved the problem by reinstalling the chromium-browser:

sudo apt-get purge chromium-browser
sudo apt-get install chromium-browser

I don't know why, but I did not lose any of my settings. I also did not have to log-in to the google-sync to get my bookmarks and stuff back, which is not supposed to be the case with apt-get purge as far as I know.

Also, the "problem" with the cookie-icon is still there. I think it's a bug or something.

At least, I still have no idea what caused the problem. All my plugins and extensions are active again, Jamendo still works.

| improve this answer | |

Reinstalling the browser didn't work for me. I found the solution here: http://help.soundcloud.com/customer/portal/articles/1185576-chromium-is-my-browser-of-choice-but-it-won%E2%80%99t-play-any-music-what-can-i-do-

Simply install chromium-codecs-ffmpeg-extra:

sudo apt-get install chromium-codecs-ffmpeg-extra

After a restart, everything operates normally !

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.