I am using a Macbook (Aluminum Late 2008 version) and dual booting ubuntu 12.10

After installation the keyboard controls for volume and brightness worked perfectly,but a few days later the brightness got stuck on high and it's been giving me headaches and is super annoying. I can't use the keyboard controls for brightness or change it in the settings. I've tried searching for a fix but nothing has worked so far. Any suggestions?

Also i have played around with the graphics drivers and i'm currently using: NVIDIA binary Xorg driver. Should i change this? (Go easy on me, i'm a newbie :))

Graphics: Nvidia GeForce 9400M/integrated/SSE2 OS Type: 32-bit I'll provide any extra information needed

  • I tried the above on my Macbook late 2009 model and it worked! Thank you so much! I did have to do all the steps though, but it was easy, if anyone else is having this issue, then try it, it works!
    – user256230
    Mar 8, 2014 at 20:16

1 Answer 1


♡ I found a solution! Hopefully someone finds this useful. I probably did more steps than required but here is what worked for me. ♡ (Nvidia users only)

  1. Open Terminal and enter the command below to open the xorg.conf file for editing:

    sudo -H gedit /etc/X11/xorg.conf
  2. Once the file opens, find Section “Device” and add

    Option "RegistryDwords" "EnableBrightnessControl=1" 

    (as shown below in bold line), and hit CtrlS to save it.

In my case, this file was empty so I entered the exact text and saved it to /etc/X11.

Section "Device"
Identifier      "Default Device"
Option   "NoLogo" "True"
Option "RegistryDwords" "EnableBrightnessControl=1″


After restarting, if this did not work for you I also did the following:

  1. Just create a file in /etc/X11/xorg.conf.d/50-nvidia.conf with the following content:

    Section "Device"
        Option "RegistryDwords" "EnableBrightnessControl=1"
        Identifier "Device0"

    Again, in my case some of these files didn't exist so I created them myself. When everything was in place I restarted and now my brightness controls are working

In order to create them manually open terminal and enter:

gksu nautilus

From there on navigate to: /etc/X11/ and create a folder named xorg.conf.d. Then inside that folder create a file named 50-nvidia.conf using gedit with the content listed in the step 3.

Now restart your computer.


  • Just to note, the first solution here worked for me on Ubuntu 20.04 on an iMac9,1 (early 2009), too. (For me, xorg.conf already existed.) Thanks! Jun 27, 2020 at 23:07
  • This prevented Xorg from running on our iMac9,1 and consoles not accessible either. Lucky we could delete the files over ssh. Jun 10 at 20:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .