49

LibreOffice always starts with the recovery process for me now. It has a number of 'documents to recover' for which recovery fails. I have no need for these documents anymore. How to tell LibreOffice to give up?

10 Answers 10

61

Great! I tried to recreate this issue and now I can't remove the failed recovery screen.

The way to fix it is to hit cancel on the recovery screen, instead of trying (and failing) the recovery (source). Works for me.

  • 14
    God what a horrible UI for this. Thanks for the response. – a coder Jun 11 '14 at 14:15
  • 3
    Interesting that 4+ years later and this "answer" is still getting attention. – philshem Mar 22 '17 at 13:16
  • 1
    Interesting that 6+ years later and this "answer" is still getting attention. – philshem Mar 4 at 8:27
  • I says "Discard" now, and not "Cancel" which makes it apparent that you can remove future recovery attempts. – SunnyDaze Mar 6 at 15:51
  • @SunnyDaze Clicking discard doesn't solve my issue, it closes the app and then retries recovery next time.. infinite loop – Alan Jun 12 at 23:23
4

Hitting Cancel as other posters suggest is not a solution for me because the same dialog keeps being shown every time I close and reopen the application.

Ubuntu 14.04.2 with LibreOffice version 4.2.8.2

The 'simple' solution for me was to do the following:

  1. close any open LibreOffice windows navigate to where LibreOffice stores registrymodifications.xcu
    • for me from a default install it's stored under /.config/libreoffice/4/user
  2. make a backup of registrymodifications.xcu
  3. edit registrymodifications.xcu with text editor (such as gedit)
  4. search for the string RecoveryList
  5. completely remove any item tags containing the path /org.openoffice.Office.Recovery/RecoveryList
    • delete from - will be one line but can appear as several if word wrap is turned on
    • NOTE: Only delete the RecoveryList items that you DO NOT, in fact, want to recover
  6. Save your changes, close the file
  7. Next time you open a LibreOffice file with LibreOffice it won't force you to go through the tedius recovery failure process

NOTE: LibreOffice writes to the registrymodifications.xcu file often while it is running - if you modify the file while LibreOffice is running your changes will be overwritten/ignored


A more robust answer (providing file locations for different operating systems, etc) can be found via this link: Question/Answer from LibreOffice Help site

  • "Hitting Cancel as other posters suggest is not a solution for me because the same dialog keeps being shown every time I close and reopen the application" - guess it is no longer the case. I was able to get rid of the dialog the first time I cancelled and confirmed that I indeed don't want the "recovery". – silverdr Feb 23 '18 at 12:47
3

This problem seems to appear in Ubuntu 12.04.

Of course you can cancel the recovery process but that's not a solution because you will have to do it every time you start LibreOffice, even after having closed all documents properly after the last session.

The bug is caused by the package lo-menubar that offers HUD functionality for LibreOffice.

So the real solution of the problem is sudo apt-get remove lo-menubar.

  • 5
    Hitting cancel as @psny18 suggests, works for me. – Jasper van den Bosch Feb 12 '13 at 10:44
  • 1
    I have this problem on Ubuntu, and I don't even have lo-menubar installed. – jplindstrom Dec 19 '13 at 12:20
2

A better solution, without messing with any configuration, set-up or so, is to write again a file with the same name in the same place.

  1. Open LibreOffice Writer (or Calc or any LO program) normally and cancel the recovery process. The program should open with a "No title" document.

  2. Write anything in the new document and save it with the exact name of the file LO is asking you to recover. If you have more than one, you have to recreate each and everyone. The name(s) has(have) to be EXACTLY the same, with the same format and in the same folder and disk.

  3. Open the fake file(s) and the problem should be fixed.

It worked for me and now I don't have the recovery window as a welcome!!!

2

Pressing Esc when the recovery notice shows up gives you the option to cancel the recovery. Then click cancel. This worked for me. See https://answers.launchpad.net/ubuntu/+source/libreoffice/+question/167956 answer #2. Don't know about answer #6. In the past this didn't work for me, so I didn't try it this time.

0

Have a look at: http://ask.libreoffice.org/en/question/6376/message-recovery-failed/

It's worked for me on Ubuntu 12.04, LibreOffice 4.0.2.4.


Summary of URL: press 'cancel' or delete the contents of

<item oor:path="/org.openoffice.Office.Recovery/RecoveryList"> (ends with </item>)

from registrymodifications.xcu.

However this appears to only be a one-shot solution - it won't turn recovery off for future files.

  • 2
    It will nice if you included resumed instructions here and point to that reference with a link . – user.dz Feb 7 '14 at 16:52
0

If you're trying to abort a repetitious "rescue", even when the window has gone to gray and seems non-responsive, you can still X out with the 'close window' in the upper left. The program offers a chance to force quit. This may be your only option if the program is trying to open a corrupted file. At that point you would think you had lost all your unsaved work. Then a surprise query opens and offers to save any unsaved files with a new name... and the "rescue" window doesn't come back!

0

So I have been looking for an answer to the same thing and the best solution I have found is to change the open command for each of the apps Instructions navigate to /usr/share/applications find the files for the libreOffice apps for me it was these four

LibreOffice App Files

right click and select properties and add --norestore to the Command

Add To Command

0

I had the same problem. I did hit recovery and when it complete the process, I hit "ESC" instead other buttons. This way it opened the App with the recoverd file and I was able to save it now it is working correctly.

PS: hitting "ESC" in the first recovery pop-up window worked but I got to do this every time I open the App.

  • In his situation the recovery seems to fail, did you have the same? – Dr_Bunsen Jun 17 at 14:09
  • I didn't try with fail. For me it recovered successfully. – Luis Sukys Jun 17 at 16:12
  • Your answer may work normally, but he speaks about the recovery failing. So the answer may not be applicable in this situation. I think this answer as a comment would have been better, until he says it worked, and than make it an answer. – Dr_Bunsen Jun 18 at 6:53
-1

Make it simple.. Please choose the cancel button and close the file.. After that it won't force you to go through the recovery process..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.