I have a Sony VAIO Duo 11 (SVD112...) which features both multi-touch and stylus input. However, booting up Ubuntu 12.10 gives me

  • no stylus reaction
  • touch input works very strange: when I touch with 1-3 fingers, usually nothing happens but sometimes there is some reaction
  • when I tap the screen with 4 fingers, the dash shows up, consistently

Where can I start to find out the underlying issue and how to fix it?

EDIT: On Ubuntu 12.04.1 the touchscreen isn't recognized at all.

EDIT2: On Fedora 18, the touchscreen works a little bit better. I have found out that the USB ID of the touchscreen is not contained in the hid-ntrig module, so that's probably why some of the quirks needed for it are not appplied.


I have filled a bug report about touchscreen. It is at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/1121379 . Please press the "affects me too" button in order to increase the "heat" and make more people/developers notice it. I can help with more tests or trying fixes. So if you have to propose something to test (e.g. install a newer kernel or X version, apply some patch, tryout some config), please tell me.

| improve this answer | |

hid_multitouch seems to be the reason for this. I need to experiment with the new kernel (3.8 RCx) with Ubuntu to see if this is fixed.

| improve this answer | |

Any luck with this? I'm a linux newbie, and I too have a sony laptop where the touchscreen is not recognised at all

| improve this answer | |
  • Welcome to Ask Ubuntu! You've posted this as an answer, but it's not an attempt to answer the original poster's question, so it may be removed soon. If you have a NEW question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. – Eliah Kagan Feb 3 '13 at 5:20

have you tried to use the method in the link below it's the same N-trig digitizer so it should work http://ubuntuforums.org/showthread.php?t=1252492&page=128

| improve this answer | |
  • Welcome to Ask Ubuntu! Please either post such "Have you tried" links as comments once you have gained the required privilege, or put the essential parts of the link into the actual answer. Only use answers for, well ... answers. – user98085 Feb 16 '13 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.