This question already has an answer here:

despite several attempts at making Google Chrome work as my default browser I simply cannot.

I've read countless threads on the internet, checked mimeapps.list and so on, tried about anything, from simple system configuration by going to settings and change as the default browser there, which, for some odd reason, won't allow me to set a default browser, to more advanced terminal scripting.

This is a clean install of Ubuntu 12.10 x64 bit updated to the latest version including kernels.

marked as duplicate by jokerdino Sep 3 '13 at 13:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you at least detail what you've tried? This question is impossible to answer if we don't know what you've tried yet. – Jorge Castro Jan 16 '13 at 0:55
  • I would love to, but since I don't have enough reputation points I couldn't even add screenshots. – Inoki Jan 16 '13 at 8:36
  • I've tried about all the manuals you can find when searching via Google. And I mean every manual related to setting Google Chrome as default browser and none of them worked. I checked settings in mimeapps.list, checked via system settings to set as default browser, checked with several commands I don't even remember they were so many. In every text file / config related to default apps setting I can see Chrome, but whenever I hit a link externally it launches Firefox? Even via Gwibber? I don't understand. – Inoki Jan 16 '13 at 8:49

As I already answered earlier on this question:

There are a number of places an application might figure out which browser to launch and unfortunately there is no established standard. If the other answers don't work for you (as was the case for me with Skype) you could try:

  • the $BROWSER environment variable
  • /usr/bin/x-www-browser, which is configured via the alternatives mechanism: sudo update-alternatives --config x-www-browser (which is what Skype is launching it seems)

When I tried, choosing the default browser from System Settings worked for me. Here is the procedure.

  • Go to System Setting > Details > Default Applications
  • Choose Google Chrome from the dropdown for Web

enter image description here

If this is not working, then uninstall your chrome. Install it using Ubuntu Tweak and Try the procedure above. Ubuntu Tweak is a must have application. To install Chrome using Ubuntu Tweak

  • First install Ubuntu Tweak from Ubuntu Software Center
  • Launch Ubuntu Tweak from Unity Dash
  • Go to Apps Tab, you will get list available apps as follows

enter image description here

  • Click on Google Chrome Stable.

enter image description here

  • Check the checkbox for "Google Chrome Official Source" and Click on Install

When installation is over, launch chrome. At the first launch, it will ask if you want to set Chrome as default browser. You can choose Yes then otherwise you can set it from System Settings > Details > Default Applications > Web.

  • I don't really see the difference between installing from Google's website by downloading the .deb file for Ubuntu x64 and installing via Ubuntu Tweak, which I had installed and it also showed, that the sources and everything were added to my computer. I constantly receive updates via software center, so even the sources work. But this is not the only case, hence I suspect this might not work for me. In addition, I cannot even set the default application for text editing, it only shows Sublime-Text 2, which I installed and doesn't give me the option to chooose e.g. Gedit again. – Inoki Jan 16 '13 at 8:38
  • Installing via Google's website by downloading the .deb file adds the sources.list also. Same goes for Ubuntu Tweak. So I don't really see how this could help. But as mentioned previously, this is not the only case. From the first screen I can only set default apps for Video, Photos and Music. The first three options are restricted for me, no idea why. – Inoki Jan 16 '13 at 8:42
  • Do you think this issue might somehow be bound to a kernel update? – Inoki Jan 16 '13 at 15:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.