Something I have noticed in Ubuntu for a long time that has been frustrating to me is when I am typing a command at the command line that gets longer (wider) than the terminal width, instead of wrapping to a new line, it goes back to column 1 on the same line and starts over-writing the beginning of my command line. (It doesn't actually overwrite the actual command, but visually, it is overwriting the text that was displayed).

It's hard to explain without seeing it, but let's say my terminal was 20 characters wide (Mine is more like 120 characters - but for the sake of an example), and I want to echo the English alphabet. What I type is this:

echo abcdefghijklmnopqrstuvwxyz

But what my terminal looks like before I hit the key is:


When I hit enter, it echos


so I know the command was received properly. It just wrapped my typing after the "o" and started over on the same line.

What I would expect to happen, if I typed this command in on a terminal that was only 20 characters wide would be this:

echo abcdefghijklmno

Background: I am using bash as my shell, and I have this line in my ~/.bashrc:

set -o vi

to be able to navigate the command line with VI commands. I am currently using Ubuntu 10.10 server, and connecting to the server with Putty.

In any other environment I have worked in, if I type a long command line, it will add a new line underneath the line I am working on when my command gets longer than the terminal width and when I keep typing I can see my command on 2 different lines. But for as long as I can remember using Ubuntu, my long commands only occupy 1 line.

This also happens when I am going back to previous commands in the history (I hit Esc, then 'K' to go back to previous commands) - when I get to a previous command that was longer than the terminal width, the command line gets mangled and I cannot tell where I am at in the command.

The only work-around I have found to see the entire long command is to hit "Esc-V", which opens up the current command in a VI editor.

I don't think I have anything odd in my .bashrc file. I commented out the "set -o vi" line, and I still had the problem.

I downloaded a fresh copy of Putty and didn't make any changes to the configuration - I just typed in my host name to connect, and I still have the problem, so I don't think it's anything with Putty (unless I need to make some config changes)

Has anyone else had this problem, and can anyone think of how to fix it?


It was my .bashrc file. I've copied the same profile from machine to machine, and I used special characters in my $PS1 that are somehow throwing it off. I'm now sticking with the standard bash variables for my $PS1.

Thanks to @ændrük for the tip on the .bashrc!

...End Edit...

  • 1
    Just to be sure the issue isn't caused by your .bashrc file, I'd recommend temporarily replacing it with a copy of /etc/skel/.bashrc. Keep in mind that you'll need to reconnect for the changes to take effect, and be sure to keep a backup of your own .bashrc.
    – ændrük
    Feb 1, 2011 at 20:53
  • 1
    Which terminal application are you using ? The behavior you are describing is not usual, certainly not a default. Feb 1, 2011 at 21:17
  • In shells that I've worked in (and in Cisco CLI) you can also type Ctrl-L to redisplay the line you are typing, even if it's offscreen. In your situation, that may still produce the broken output you're talking about, but I'd be curious.
    – belacqua
    Feb 1, 2011 at 23:26
  • 3
    Feel free to create an "answer" explaining the solution and mark it as accepted. It can seem a little silly, but having a proper answer helps keep the site organized and might more effectively guide others who have similar problems in the future.
    – ændrük
    Feb 2, 2011 at 5:07
  • As per this answer on serverfault, use tput smam
    – Samveen
    Oct 23, 2017 at 10:37

8 Answers 8


Make sure all non-printable bytes in your PS1 are contained within \[ \]. Otherwise, bash will count them in the length of the prompt. It uses the length of the prompt to determine when to wrap the line.

For example, here bash counts the prompt as 19 columns wide, while the prompt displayed by the terminal is only 10 columns wide (My prompt written in cyan, and > written in default color):

PS1='\e[36mMy prompt\e[0m>'         # bash count: 19, actual: 10

while here it only counts the prompt as 10 columns wide because it ignores the bytes between the special \[ and \] escapes:

PS1='\[\e[36m\]My prompt\[\e[0m\]>' # bash count: 10, actual: 10

For good practice though, use tput to generate the terminal escapes rather than hard coding them:

cyan=$(tput setaf 6) # \e[36m
reset=$(tput sgr0)   # \e[0m
PS1='\[$cyan\]My prompt\[$reset\]>'

For more information see the following resources

bash prompt: http://mywiki.wooledge.org/BashFAQ/053

tput: https://linuxcommand.org/lc3_adv_tput.php

  • 3
    That's a great explanation of the problem that the accepted answer doesn't provide
    – Jamie Cook
    Oct 2, 2013 at 0:41
  • In the last line of code PS1='...' : why don't single quotes prevent $cyan and $reset from substitution?
    – andrybak
    Nov 15, 2015 at 13:52
  • 4
    @andrybak, they do prevent $cyan and $reset from being substituted, but PS1 is evaluated every time the prompt is printed. You can see this by trying PS1='$var> ' and then give var various values and see how the prompt change. Then try PS1="$var> " and notice that the prompt remains static; $var got expanded during assignment, not every time PS1 is evaluated.
    – geirha
    Nov 16, 2015 at 19:52
  • 1
    This is amazing. Thanks so much for posting this! It makes escaping the square brackets much easier and more readable.
    – phyatt
    Dec 1, 2015 at 20:41
  • 1
    @winklerrr the \[ and \] in PS1 actually get translated to \1 and \2 before it's handed to readline, so it's actually the same, just that when you're dealing with readline directly, you need to use its own \1 and \2.
    – geirha
    Feb 25, 2020 at 7:51

I guess you have configured your PS1 with colors, right?

Just make sure you have \[ inside your PS1 quote preceding your color set

For example:

PS1='\[\e[0;32m\u@\w/:\[\e[m '
  • My PS1 was export PS1='^[[96m'$(hostname)'<^[[92m${PWD}^[[96m>^[[97m ' - I've been using that one for a long time - it's KSH compatible...
    – BrianH
    Feb 2, 2011 at 16:48
  • 2
    Wow. I've been using terminal prompts since forever and never had this problem before. Would have never figured that out. Thanks.
    – bchurchill
    Sep 30, 2013 at 21:51
  • 3
    using \[ while using simple quotes yields an unintended slash. also, there should be used ] in the end of the magical chars, as noted in the best-voted answer Jul 3, 2014 at 21:32
  • 3
    -1 Doesn't work. You need to wrap the non-printing section with \[ at the start and \] at the end.
    – wjandrea
    Oct 29, 2017 at 0:52
  • @igorsantos07 The double-backslash in \\[ was a typo caused by an edit. I've fixed it.
    – wjandrea
    Oct 29, 2017 at 0:53

I had a similar issue, and finally found a simple solution.

Add following line in your .bashrc file:


Then type source ~/.bashrc to get the desired effect.

  • In some cases, such as narrow terminator subdivisions, the problem is not in the promt color characters but just in a wrong COLUMNS value. This answer took me out of a very bothering hole! Jan 13, 2014 at 13:31
  • 1
    Logging off is unnecessary. Do source .bashrc. Your prompt will update immediately Aug 17, 2015 at 1:24
  • 2
    I found that since I didn't have shopt setwinsize set for my bash, so it wasn't updating COLUMNS right, see unix.stackexchange.com/a/167911/8337
    – rogerdpack
    Sep 11, 2015 at 22:11
  • 1
    I did export COLUMNS=250 followed by export TERM=xterm and it was happy. Aug 2, 2016 at 14:18

A simple thing to do would be to add the following line before setting the PS1:

stty columns 1000

For example,

stty columns 1000
PS1='\[\e[0;32m\u@\w/:[\e[m '

however this does affect other unix commands like ls and man.

  • 1
    That works in OSX.
    – raskhadafi
    Jun 26, 2014 at 7:12
  • 4
    This also affects vim badly. Please don't use this.
    – justhalf
    Dec 28, 2015 at 7:21
  • 1
    this is the only thing that worked for me. Dec 12, 2020 at 15:42

I had the same issue with a custom coloured prompt, even though I contained colour codes within \[ and \] delimiters. It turns out that bash has problems echoing colours from inside a function. I ended up just using variables for my prompt, and though my .bashrc is a little less elegant, everything works nicely now.

  • If anyone's still reading this, it is actually possible to escape colors in a function. See this answer on the linked question.
    – wjandrea
    Oct 29, 2017 at 1:20

I had this problem when connected in tmux. The problem was that I had an ipython session in the background (ctrl + z) and that somehow broke line wrapping. As soon as I terminated it (fg, ctrl+d+d) my terminal started working properly

So check for any stopped interactive prompts.


So I just had the same issue with a slight twist on it and I thought I would share my solution too, just to add my little nuance :D

My initial PS1 was


The problem I had was that I was trying to change my terminal title as well as the command prompt. The way I did this was by adding \[\033]0;\]Title\a to the PS1 variable.

So now my PS1 was:


This messed up the line wrapping for me. I finally figured out that bash doesn't seem to like having \a at the end. To circumvent this, I put the title in a variable, which seemed to fix it.


\[ and \] didn't work for me. I guess there was something different about how I was generating the prompt (from an external program), or because my prompt was "dynamic".

After reading this I found that you can actually escape the color codes with the 0x01 and 0x02 bytes.

e.g. I'm using a special version of Chalk and I wrap the colors using this:

const Chalk = require('@nasc/chalk');

const chalk = new Chalk.constructor({
  wrapper: {
    pre: '\1',
    post: '\2',

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .