I want to turn my dual-boot ThinkPad T400 winXP + ubuntu 12.10 into single Ubuntu machine, i.e. delete Windows and recovery partitions, and use all the disk space for Ubuntu.

Before doing so, I would like to create a recovery media (cd/dvd or backup to external hd). And here a problem starts.

Lenovo provides Rescue and Recovery software that makes possible to create recovery disk in Windows. However, I can not use it to create recovery cd because after installing Ubuntu the software does not see the recovery partition and can not copy the data to a cd. I think it is related to this: http://www.thinkwiki.org/wiki/Rescue_and_Recovery

The service partition is visible in Grub but it does not start when run (i guess it's the thing described in the link above). However, in Windows nor in Ubuntu the partition is not visible, and I do not know how to access it.

Does anyone have an idea what to do in order to create the recovery media and what things later have to be done when I would like to use it?

The best option for me would be if, I could also be able to create a Windows virtual machine form this recovery media. Any ideas?


  • what I need to change in the config to make it run? current configuration of the partition is as follows: insmod part_msdos insmod fat set root='hd0,msdos2' if [ x$feature_platform_search_hint = xy ]; then search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2 DBF9-E3D0 else search --no-floppy --fs-uuid --set=root DBF9-E3D0 fi drivemap -s (hd0) ${root} chainloader +1 – feedyourhead Jan 16 '13 at 20:15

Regarding viewing the drive through Ubuntu, usually Ubuntu will auto-mount any partition types it recognizes, so if that's not happening, maybe it is a file system type that isn't supported without something else being installed. Or perhaps you simply need to mount it manually. If you run sudo fdisk -l, this may help identify the path to the the partition.

Once you have it mounted in Ubuntu, you can then consider dd'ing the contents of the partition to a file, from which in the future, you could rebuild the drive.

| improve this answer | |
  • Thanks. I've tried it but I can't mount in Ubuntu nor run the disk from GRUB because there are some errors (in ubuntu "Device or resource busy (udisks-error-quark, 0)" ) When I try to run it through GRUB, after initial loading I get a blue screen and recommendation to run chkdsk /f but can't do anything without mounting the drive first – feedyourhead Jan 18 '13 at 21:35
  • Probably a dead end, but worth checking your /etc/fstab entries look okay. I saw someone got the same error when their fstab was screwed up: bbs.archlinux.org/viewtopic.php?id=62223 (you could try removing the fstab entry for that partition---if there is one---then reboot, and try a manual mount of the partition. – Dolan Antenucci Jan 18 '13 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.