I'm trying to set up the VPN for my university on my laptop. I have downloaded to certificate file and put it in ~/misc/cacert.crt. When I try to set up the VPN, I click on the CA Certificate option and navigate to ~/misc/ in the selection menu. The certificate does not appear there. The folder appears empty. I tried adding a new version of the file that is named differently, also doesn't appear in the menu. I can double click on the file in nautilus and it brings up a little box with the details of the certificate, so there's nothing wrong with the file.

Any idea what's causing this bizarre problem?

I've found something out. If I do file cacert.crt I get data whereas if I do file on a .crt certificate that does show up (which I found in /etc/ssl/certs/) then I get PEM certificate. So presumably having .crt is not enough and the VPN setup wants file to return a valid certificate type? How do I change this?

grep 'crt' /etc/mime.types gives me application/x-x509-ca-cert which, as I understand it, should mean that *.crt files are recognised as certificates. So why is my cacert.crt only appearing as data?

  • 1
    My answer here might be helpful. – user76204 Jan 15 '13 at 18:03
  • That doesn't seem to have helped. I've put copies of the file in a number of different directories and run update-ca-certificates but with no luck. The file just doesn't show up in the selection menu. – Seamus Jan 16 '13 at 13:00

It may be too late to help you, but I'm posting this here for future reference. I had the same problem. I ended up just typing the file name in the address at the top and it worked. Took me an hour to figure it out though.

| improve this answer | |

I did not have a location field, but was able to work around this by:

  1. Click the CA cert box, right click the folder and click "open file with file manager"
  2. Cancel out of that but keep your file manager open
  3. Drag and drop the pem file to the CA cert box in the network config dialogue.

This was with bionic before official bionic release.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.