This question already has an answer here:

I installed IP Messenger (GNOME 2) from Ubuntu software center but its not working. It's always showing an error message on Ubuntu 12.04.

Can not setup lock file:/tmp/g2ipmsg.lock errno : -11 (Resource temporarily unavailable)

marked as duplicate by Eliah Kagan, muru, Eric Carvalho, David Foerster, Zanna Jan 15 '17 at 13:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • To add to it, if anyone sends a message, g2ipmessenger crashes – Ubuntuser Feb 22 '13 at 8:40
  • @Madhu K. Did you got any solution for this problem so far? As i am having the same issue with Ubuntu 13.10 – mohit_rocks Dec 14 '13 at 6:54
  • 1
    did you try this – Avinash Raj Dec 14 '13 at 7:03
  • @AvinashRaj I tried but it doesn't work. – mohit_rocks Dec 14 '13 at 9:33
  • 1
    I've just solved it. – Ravi Dhoriya ツ Jun 16 '15 at 8:37

Try to check first about /tmp/ directory and that it is writeable by all users.

Also try this solution :

  1. Type on terminal below command - gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

  2. Restart and click gnome ip messenger still it may give create lock file error but it will be viewable in notification panel.

  3. If still this doesn't work make sure that you can write to /tmp, try touch /tmp/foo to make sure you can write in it

  4. Next, see whether there is a lock file in /tmp: ls -l /tmp/g2ipmsg.lock if you can't see try with sudo ls -a /tmp/

  5. You can see know who owns the lock file. If there is a lock file, check whether the process is running with pgrep ipmsg. If not, remove it: rm /tmp/g2ipmsg.lock or sudo rm /tmp/g2ipmsg.lock

Let us know if it worked

  • "No such schema 'com.canonical.Unity.Panel'" error – Mr. P Nov 15 '14 at 7:55
  • Hi Parth, for this error you should check this article :… Let me know if you were able to solve it. – yilmi Nov 19 '14 at 12:25

I have also same problem. Here you can try alternative Iptux. You can send/receive message to/from ipmsg on windows and iptux on Ubuntu.

To install iptux use command :

sudo apt-get install iptux
  • but it cannot receive msgs from windows systems... i am using it.. its not good – Mr.Popular Feb 25 '17 at 7:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.