11

Since installing 12.10, Chrome has been displaying bizarre colored artifacts over youtube videos, I can still watch the videos, but it's more than a little irritating.

I've installed Chromium, and there is no problem there. I assume then, that it is an issue with the built in Flash plugin that comes with chrome.

Here is a picture of the colored artifacts:

enter image description here

Any help appreciated.

4
  • 1
    So if it's an issue with Chrome's flash plug in then just disable it, then set it to use Ubuntu's flash plug in. Jan 15, 2013 at 3:41
  • 1
    The solution suggested by Uri Herrera worked. I installed the Flash Plugin from the software center, then entered chrome://plugins/ in the Chrome address bar. Scroll down and find the two instances of Flash, and disable the pepperflash version.
    – Dan
    Jan 15, 2013 at 5:55
  • 1
    @Dan It would be particularly valuable for you to post that (or something similar) as an answer, since it appears this may also happen due to a bug. Right there, as far as I know, there's nothing visible for people to find when searching, that explains the problem can be caused by multiple flash plugins being enabled simultaneously (at least, assuming I'm understanding what you're saying). Jan 19, 2013 at 2:08
  • A possibly relevant bug is being tracked here: Flickering rectangles like a swarm of bees when watching youtube and vimeo videos.
    – user25656
    Jan 24, 2013 at 5:34

3 Answers 3

8

This is because of a documented, gpu compositing bug: Issue 164555: Flickering rectangles like a swarm of bees when watching youtube and vimeo videos. On affected systems, yellow snow is seen when viewing Flash videos and orange snow is seen when viewing HTML5 content.

It involves the Pepper version of Flash and certain Mesa drivers.

Running Chrome with the Pepper Flash but with the --disable-accelerated-compositing switch stops the snow from appearing but WebGL function will be lost.

The other Flash, NPAPI Flash, also used by other browsers such as Firefox, isn't affected possibly because "the NPAPI plugin doesn't use the GPU process and probably just provides software rendered frames".

There are thus two workarounds: disable the Pepper Flash and enable NPAPI Flash (if it is installed)
or
continue using the Pepper Flash but with the --disable-accelerated-compositing switch

Read the bug for full details.

0

This is not a problem with Flash plugin, but with HTML5 video. While I don't know the exact cause, I suggest that in the meantime you disable YouTube's HTML5 support (in http://youtube.com/html5)

1
  • For me the HTML5 test was switched off. When I enable it the color of the noise changes from yellow to orange.
    – highsciguy
    Jan 29, 2013 at 21:27
0

Disable the chrome PepperFlash plugin as described here: http://www.enounce.com/chrome-disable-pepperflash . See also here How to solve jitter (or stutter) playback via Chrome flash plugin? and here https://superuser.com/questions/537679/yellow-noise-small-lines-when-chrome-is-playing-video .

Not the answer you're looking for? Browse other questions tagged or ask your own question.