I've been using Ubuntu(12.10) for a long time, and recently, my Ubuntu went through yet another update.

The whole update prompt showed up, following by a password prompt, and finally the good ol' progress bar...

Everything went well, and later on, I shut down my computer.

The next day, I turned my PC on, went to the login screen. I went ahead, and logged in, but after that, all I could see was a black screen, and my cursor!

I checked the forums, and got various tips, none of which worked...

Now I'm stuck with an Ubuntu installation that's completely useless.

One more thing:

I even tried logging in through Guest, but same problem! :\

My Computer Specs:
Motherboard: Intel DG41WV
Processor: Intel Core 2 Quad Q6600 @ 2.40GHz
Graphics: Intel G41 Express Chipset
RAM: Dual Channel, DDR3 2*2GB (4096 MBytes)
HDD: Seagate 500GB SATA


To be a little more precise about my problem, after I log in, I can see a black screen and my cursor. Plus, importantly, I was able to see a login screen, hence I'm sure Ubuntu is rendering properly, and also pretty sure that there's no problem with the drivers (Otherwise I shouldn't even get a login screen, right?).

Anywho, another (probably) important thing is that, after logging in, I can hit Ctrl+Alt+1 and get up a recovery console.

The only thing that doesn't load is my actual GUI desktop

Then, I ran unity from the recovery console, it went through a few commands, got stuck at OpenGL for a few seconds, then zoomed throught many more lines of code, and ended up with this:

ERROR 2012-01-03 20.51.23 unity.launcher.Icon TrashLauncherIcon.cpp:62 Could not create file monitor for trash url: Operation not supported

*** glibc detected *** compiz: malloc(): memory corruption: 0x09c861d6 ***

After that. back at Ctrl+Alt+F7: Desktop Background + Cursor

So back to the terminal again, I had to hit Ctrl+C to get back again.

now, I typed unity again, and this was the output:

WARNING: no DISPLAY variable set, setting it to :D
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
unity-panel-service: no process found

so now I did a sudo service lightdm restart :

X10: fatal IO error 4 (Interrupted system call) on X server ":0"
after 131 requests (130 known processed) with 0 events remaining.
lightdm stop/waiting
lightdm start/running, process 2852

Im back at the login screen, and I login again, now Im back to black screen (Yes, I lost the Desktop Background as well)

So, once again, I try unity (same response as last time):

WARNING: no DISPLAY variable set, setting it to :D
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
unity-panel-service: no process found

And still a black screen! :\

  • 1
    Have any active PPAs that we might need to be aware of? Jan 14, 2013 at 10:29
  • "I checked the forums, and got various tips, none of which worked..." Why don't you concisely summarize those so that people don't "resuggest" them only to be told that that doesn't help?
    – user25656
    Jan 14, 2013 at 10:36
  • Can you try booting using the classic DM?
    – To Do
    Jan 14, 2013 at 11:27
  • Hey Bruno... Umm, I'm not sure exactly what you might NEED to be aware of.... I've got a few repositories added, and i have apps from these that work perfectly.... However, You should know, this happened after an update... Jan 14, 2013 at 13:17
  • @vasa1, I've gone through quite a few, I've lost track of which ones and what the tips were... Besides, I'm pretty sure even If I have seen a tip before, I must have messed it up last time, so here I can get some feedback too... Jan 14, 2013 at 13:21

6 Answers 6


Just for completeness, this problem also occurs when you mistakenly installed the "nvidia-319-updates" package, but you do not have an nVidia graphics chip on your system. In my case this package was an indirect dependency from package "libopencv-dev".

So, when you're running on an ATI or Intel grpahics chip for example, and you installed openCV (package libopencv-dev), OpenGL gets broken and you'll get a black screen with mouse cursor after logging in. To resolve in this case, just remove nvidia's packages:

sudo apt-get remove nvidia-*

See this bug on launchpad for more details

  • Or a host machine with an NVIDIA card running a VM.
    – geometrian
    Apr 19, 2014 at 22:09
  • Thanks - this fixed my problem after I mistakenly tried to get the Nvidia CUDA compiler to work on my laptop (I have an AMD graphics card).
    – nebffa
    Sep 28, 2014 at 5:50

I've successfully solved the problem. Well, what I did was this:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:unity-team/staging

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity

That, followed by a reboot, is the recipe for a fix! :D

  • 3
    Could you please ELI5 what this does? Sep 6, 2013 at 17:38
  • 2
    Well, this didn't work for me. Sep 6, 2013 at 17:45
  • Also, i accidentally remove my desktop. sudo apt-get update sudo apt-get install --reinstall ubuntu-desktop and sudo apt-get install xfce4-goodies as my desired desktop is xfce, using above commands solved my problem and my machine boot up
    – EsmaeelE
    Aug 26, 2017 at 19:35

Maybe you need to reset compiz and Unity config files.

You can try a soft reset (only Unity/Compiz files, but I didn't test this): http://www.webupd8.org/2012/10/how-to-reset-compiz-and-unity-in-ubuntu.html

There's a hard reset: https://askubuntu.com/a/244064/123806

But it will erase config of some apps. Try it as a test user, go to tty1 (Ctrl+Alt+F1):

sudo adduser test

Return to tty7 (Ctrl+Alt+F7) and try login. If works, we confirm it's just a problem in your config file. Else follow the link above. (after tests, "sudo deluser test" and "sudo rm -Rf /home/test" will erase).

If Ctrl+Alt+T doesn't work...

First login and get blank screen, then Ctrl+Alt+F1, backup and remove your config file:

cp .config/dconf/user .config/dconf/user.bkp
rm .config/compiz-1/compizconfig/config .config/dconf/user

We need to remove both files at same time.

Ctrl+Alt+F7 and the expected is Unity will open.

  • Hey, thanks for the reply. However none of the methods worked. The soft reset throws a dconf bus error. The hard reset method: after making a new account, same problem there, except the desktop background shows up now as well. Jan 17, 2013 at 16:05
  • Thanks, removing the config files worked for me (on 13.10).
    – tectux
    Aug 21, 2014 at 12:32
  • compiz --replace worked for me, thank you!
    – RedClover
    Aug 6, 2019 at 11:09

I had same issue, but i noticed that after running

sudo apt-get remove nvidia-*

command, which did not changed anything (even after reboot)
there were some old unnecessary packages, and after removing them with command

sudo apt-get autoremove

and rebooting all was correct, desktop is loading as expected.

  • 1
    sudo apt-get autoremove was the solution for me. Oct 18, 2015 at 0:28

I had the same problem, and a shorter fix worked for me:

unity --reset

Followed by:

sudo service lightdm restart

Trouble is, you lose settings such as icon sizes, etc. These can be easily reconfigured using MyUnity or UbuntuTweak (from the software center).

(However, the problem comes back every time I connect an extra display to my laptop before booting. But that's a different problem, I presume. Discussed here: Ubuntu 12.04 Unity: Black screen with cursor only, when external display is connected before booting laptop)

  • Haha, you're early! :P Nah, your solution: that's the first thing I tried. Didn't work for me though :( Jul 20, 2013 at 22:36
  • Good to know. That means that while our symptoms are the same, the problems are not completely related. Or at least, are caused by different things. Jul 22, 2013 at 7:13
  • Well, they both do seem to be problems with unity. That's for sure! :P Jul 22, 2013 at 9:44





sudo update-grub
sudo reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .