I have been working at this problem for 2 days now. I cannot for the life of me enable 3D support in VMWare 9 guests.

My specifications are:

Hardware: Dell Latitude E5520 laptop.
Processor: Intel i7-2620M CPU @ 2.70GHz × 4.
Memory: 8GB.
Video: Intel Sandybridge Mobile x86/MMX/SSE2
OS: Ubuntu 12.04.1 LTS, 32 bit.
Vmware Workstation: 9.0.1 build-894247
Glxgears functions fine. Frame rate is ~60fps.
Vmware guest: Windows 7

Starting the Windows 7 guest in VMware throws the following errors:

  1. No 3D support is available from the host. and
  2. Hardware graphics acceleration is not available.

I've read through this VMware forum thread, but again the hardware in the post is different (nVidia).

I've followed the instructions at this Ask Ubuntu post as closely as possible as the question is nearly the same as mine although my hardware is different.

Answer 1 regarding setting mks.gl.allowBlacklistedDrivers = TRUE; in my vmx configuration file causes the VM to crash when it starts.

The second answer I followed as closely as possible.

  • I uninstalled VMware,
  • Did sudo apt-get install build-essential linux-headers-$(uname -r) at a terminal,
  • Added the PPA https://launchpad.net/~glasen/+archive/intel-driver,
  • Then at a terminal did sudo apt-get update && sudo apt-get upgrade -y

I reinstalled VMware and have the same results: no 3D in guests.

I'm getting the feeling that something is awry with the Sandy Bridge driver, but I can't seem to come up with any solutions. Has anyone out there run across this problem also?

By the way, the operation of the likes of Solidworks and AutoCad within a Windpws 7 guest does appear to be improved in VMware 9 vs VMware 8 in spite of the fact that 3D support is lacking in the Windows 7 guest.

I'd also add that my glxinfo file was nearly identical to the glxinfo file posted at askubuntu.com/questions/181829/…. I had a total of seven minor differences per a comparison using Meld. –

  • I'd also add that my glxinfo file was nearly identical to the glxinfo file posted at askubuntu.com/questions/181829/…. I had a total of seven minor differences per a comparison using Meld.
    – jjapol
    Jan 14, 2013 at 1:15

2 Answers 2


Probably bubmp, this worked to me on debian 8: How to fix 3D Acceleration for Vmware Workstation 9?

About mesa part: I installed: apt-get install mesa-utils

Then I've checked OpenGL support in xserver.

user@linux:~$ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.3.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.3.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
OpenGL ES profile extensions:

Then I added: mks.gl.allowBlacklistedDrivers = "TRUE" to end of *.vmx file. This worked for Windows 8 and Windows 7 VMs.


I have the same problem maybe these suggestions I've dug up from other threads will work for you.

I've run the intel-linux-graphics-installer updated my drivers. I've installed DRI and enabled S3TS Texture Compression.(solved problem on Ubuntu 12.04 machines) I've looked for fixes on multiple posts. I wish I understood exactly what was going on and I'd fix it but I don't know what else to do to enable 3D acceleration. I do have 640x480 and it does run.

VMWare 9.0.2 build-1031769 Ubuntu 13.04 Intel® Core™2 Duo CPU T7800 @ 2.60GHz × 2 Intel® 965GM x86/MMX/SSE2 My thread: Enabling 3D acceleration VMware 9 Ubuntu 13.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.