I'm running Ubuntu 10.10 on my laptop (an Asus G73j), dual-booting Windows 7 if that matters. After using the computer for couple of hours or so, I get a popup complaining that a file was unmounted, then my GNOME desktop panels disappear. I can't save any unsaved work (the file browser shows "Filesystem" as totally empty), and other programs break in odd ways (like Chrome can't browse to any new pages, but keeps current ones going... at least I still have Pandora to listen to when this happens!).

I've tried looking in the system logs to no avail; I'm assuming that it can't write any errors to the logs because, of course, the logs are on the primary hard drives.

This started happening maybe a few days ago. Yesterday I upgraded from 10.4, but I believe it was happening before then. Any advice for figuring this out?

EDIT: It just happened again, and I heard a small little clicky sound from the hard drive about five seconds before things went south. I'm thinking I should start backing up ASAP.

In response to a comment, here's the dmesg output: http://askubuntu.pastebin.com/uYGshBay

Also, the SMART status says the disk has a few bad sectors, and the detailed data says there are 14. It says it passed the self-assessment though.

Lastly, this doesn't seem to be happening when I'm on Windows. I recently re-enabled ureadahead (which I disabled ages ago because it was causing Ubuntu to hang at the startup logo), could that be the source of the problem? I've disabled it again to see.

  • Please post the output of the dmesg command, or the last lines from syslog in System->Administration->Log File Viewer. You can also check the SMART status in System->Administration->Disk Utility – Javier Rivera Jan 31 '11 at 9:19
  • There is nothing interesting on the dmesg log but the fact that the disk was unclear at boot. This is expected if it hardlocked. :(. – Javier Rivera Jan 31 '11 at 12:03
  • The dmesg output shows issues with ACPI, and I suspect that Linux does not perform proper powersaving for your computer. You can try to update to the latest BIOS in case it is fixed. – user4124 Jan 31 '11 at 12:14
  • That sounds right: when I hibernate, it goes to a blinking cursor, and then after a little while the cursor stops blinking, but it never actually shuts down. – Twisol Jan 31 '11 at 12:42

The dmesg output shows filesystem errors. Therefore, the message you got was probably about remounting the root filesystem as read-only, and not allowing you to write on it, until it gets fixed.

What you need to do is provide S.M.A.R.T. information for your hard disk to figure out whether the problem is actually a hardware issue. Apart from Disk Utility you can use

sudo apt-get install smartmontools
sudo smartctl -a /dev/sda

Then, any output you get from about put it on PasteBin. This will show if you have any hardware issues with your hard disk.

|improve this answer|||||
  • Actually, the message I got was from Dropbox, saying that since something had been unmounted, it was closing to prevent accidental deletions. I've dealt with read-only filesystems before (well, one) and I was still able to at least browse the system. The filesystem doesn't even exist for me. (For example, I tried to 'ls' last time it happened, and it said '/bin/ls not found' or something like that.) – Twisol Jan 31 '11 at 12:40
  • smartctl output: askubuntu.pastebin.com/TEgzEJJz – Twisol Jan 31 '11 at 12:48
  • S.M.A.R.T. shows indeed that there are 14 bad sectors. It is not critical (there are about 100 spare sectors on a typical hard disk). I did not see a very high temperature from S.M.A.R.T., a long test took place recently and was successful. These bad sectors was a recent incident, and you need to keep an eye for potential future deterioration of the disk. Keep this pastbin output for future reference (and compare). – user4124 Jan 31 '11 at 13:18
  • That's good to know, but if that's not the problem, what is? – Twisol Jan 31 '11 at 19:07
  • The state that you are in now is that your hard disk got a hardware incident. These things happen, either due to high temperature (not your case), either due to shock, either due to random hardware damage. Once a filesystem check is performed, the system should be OK to continue to use. However, since this incident got you 14 bad sectors, you should get a backup anyway of your files. And, you should keep a close eye on the hard disk (Disk Utility) and whether those 14 bad sectors increase. If you get more bad sectors, then replace hard disk (cost: ~$70). – user4124 Jan 31 '11 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.