14

The volume control icon is missing from the panel. The n/w and battery icons are shown. When I try to edit the Notification Area from the Panel preferences I see the volume is not available as a known app. I need help. Am a newbie :)

1
  • I meant "known applications" when I said recent apps. Commented Jan 13, 2013 at 6:00

6 Answers 6

21

The volume control icon is part of the xfce4-indicator-plugin, which can contain various icons. You can accidentally remove the volume control icon, which will close the plugin; when it is running it is listed in system monitor as xfce4-indicator-plugin.

To return to your old panel setup as displayed here: , please follow these instructions.

(Only the volume and mail icons are actually part of the indicator plugin; the networking and power-management icons are separate plugins).

1) Just right-click the panel and go to panel preferences, as in the screenshot below:

enter image description here

2) Then, just make sure the appropriate panel is selected, move to the items tab and click the green + in the items tab (not the one at the top of the screen) to add an item.

enter image description here

3) Now, scroll down the list and select the indicator-plugin, click add, and close the menus. Your volume control icon and mail icons will be restored.

enter image description here

This should sort out your problem unless you have uninstalled some xfce4 items or icons.

1
  • Thanks a lot. That did it :) I'm still new to this community, in the future I shall check the database thoroughly before popping in a question. Commented Jan 17, 2013 at 6:53
7

I ran into this in an Ubuntu installation that I had installed the xfce4 pacakage on, not a proper Xubuntu installation. But in case if anyone else has the same problem, I had to install the indicator-sound-gtk2 package:

sudo apt-get install indicator-sound-gtk2

and then log out/log back in.

1
  • Using your answer and this one, i finally got my volume control back! :)
    – Lars
    Commented Dec 7, 2013 at 15:00
1
sudo apt-get install xfce4-mixer  

This installs a plugin that you can add straight to any panel.

2
  • 1
    This didn't work on a new install of xUbuntu 16.04LTS where I'm using the notificatin area instead of the buggy "indicator plugin" but sudo apt-get install xfce4-pulseaudio-plugin did.
    – jtlindsey
    Commented Nov 17, 2017 at 11:04
  • 1
    @jtlindsey You should add your comment as a separate solution. It will be easier for others to find and will be more helpful that way. Commented Nov 18, 2017 at 21:48
1

That's not intuitive. You need an icon separate from the notification area called "sound icon" or "volume control." This is a common problem. (EDIT: answer in 16.04 be sure to install & add to panel: 'xfce4-pulseaudio-plugin' current version is 0.2.4-1 as of 7/2017 Seems to work fine, ugly icon but you can also just hover & mousewheel it up and down. )

I was using an indicator that I like better than the standard one,that shipped with 13.04 to 16.04 (I think) using the indicator-plugin, it is called "Volti" and it's available for Precise and Oneric. (EDIT... AND the rest up to ZESTY. Current version 0.2.3-7 from Zesty works on 16.04 as well.) Simply add it using Synaptic (or, I imagine, the Ubuntu Software Center.) This uses ALSA without having to use Pulse Audio, as well. Unfortunately there is a problem where it does not work after resume from suspend! :( Have to kill it then restart it. Info: code.google.com/p/volti/‎

0

I am missing the volume icon in Xubuntu 14, and the solution here didn't work for me (I already had the Indicator plugin added to the panel). The only way that worked (and I also use this when the panel has other issues too), is to restart the panel, using:

xfce4-panel -r

I actually have this setup as an alias in ~/.bashrc since I run into panel issues as lot.

alias panelbug='xfce4-panel -r'
0

Similar to @Ulad answer, if you want to install a sound plugin that will work with your panel, try

sudo apt-get install xfce4-pulseaudio-plugin

That worked for a new install of xUbuntu 16.04LTS where I'm using the notification area instead of the buggy "indicator plugin".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .