I just installed ubuntu from scratch.However plain installation does not include nvidia driver initself so I installed it from 'additional drivers' tool but it crash the ubuntu and take the resolution and Unity down. I looked at all the posts on Internet and come up no working solution. I install nvidia-current than remove , install nvidia-current-update than remove. I tried all the possibilities that are proposed on internet. Only working solution was removing all the nvidia related packages with apt-get remove nvidia* then installing nouveau by apt-get install xserver-xorg-video-nouveau. It takes all the things as usual but I guess without correct nvidia driver. Am I installing wrong driver or what? Wha might be the problem?

My graphical card is Geforce GT635M on Ubuntu 12.10

| improve this question | | | | |
  • Am I installing wrong driver? If you system is working correctly, without temperatures issues, without performance issues, without graphical problem, then you have the correct driver. Also, If you are having troubles related to your graphic card driver, you must tell us what model it is. – Lucio Jan 12 '13 at 22:43

MY solution goes with the link https://wiki.ubuntu.com/Bumblebee#Installation

| improve this answer | | | | |
  • 3
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Seth Jan 12 '13 at 23:41

There's nothing wrong with using the Nouveau driver if it is working for you. It's simply the open-source driver that is freely available. Problems with the proprietary NVidia device modules on some older cards means that the Nouveau driver is sometimes the best option.

Thank goodness for the Xorg nouveau driver!

| improve this answer | | | | |
  • at that case I cannot use the xserver settings for nvidia card – erogol Jan 12 '13 at 22:57
  • Yes you can. Settings are done in System Settings --> Displays. It's the NVidia modules that don't play nice with xorg, in which case you have to use the program nvidia-settings. – fabricator4 Jan 12 '13 at 23:04

If I understand correctly that when using the Nvidia drivers, you're seeing only the desktop and not Unity, then it seems to me you ran into this bug (there are a few variations of it):


If this is indeed the case, than for some reason, kernelheaders related to you graphic display (headers essetially link different bits of the kernel or kernel and userspace together) got corrupted. I had the same problem. In my case it was caused by switching to a low-latency kernel. Switching back to the regular 12.10 kernel didnt help because the headers stayed the same. I resolved it by falling back to the 12.04 kernel from which I upgraded a few months back. In 12.04 the Nvidia drivers worked correctly. I removed the later kernels and then upgraded again. This fixed it and now I am again running Nvidia prop drivers on 12.10

In your case however that is not a direct option because you dont have a 12.04 kernel to fall back to. In some cases this:


will work.

If it doesnt, what you may have to do a reinstall of Ubuntu.Thats not as dramatic as it sounds, providing you have your /home in a seperate partition. There are a lot of places where you can read how to do that.

Hope this helps to resolve your problem. Let us know how you get on.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.