Upgraded from 10.04 to 10.10 removed hibernate option for me and introduced the problem where by after entering standby (being indicated by blinking amber LED on my laptop) I cannot resume my session. Instead I get a crash and system reboots (crash comes instantly on trying to resume).

Tried clean install to eliminate possibility of an upgrade issue but its still persistent. All latest updates installed.

Tried looking for an answer to this but still no joy. Laptop is Sony VGN-FW41E.


2 Answers 2


If the solution below does not work for you, try this one:

  • Edit the file /etc/default/grub (as root)
  • Change the line with:



  • run update-grub (as root)

Worked for me... Hope this can help you!

  • Works perfectly on my Sony Vaio F11. Thanks a bunch!
    – jfoucher
    May 13, 2011 at 21:33
  • I lost my wi-fi connectivity on rebooting afte rmaking above changes. Hibernate worked though!!!
    – Deep
    Sep 23, 2014 at 16:50
  • 1
    works on Ubuntu 14.04 as well Apr 1, 2015 at 20:15
  • works on ubuntu 15
    – CESCO
    Nov 29, 2015 at 15:15
  • 4
    What does acpi_sleep=nonvs mean? Nov 9, 2019 at 8:39

I've solved a similar issue (reboot on resume) with a Sony Vaio VGN-FW51ZF by changing the last line of the file /etc/acpi/sleep.sh from pm-suspend to pm-suspend --quirk-radeon-off (guess it was a problem related with ATI proprietary drivers).

Hope this can help you!

You must log in to answer this question.