I installed ubuntu 12.10 on my Dell Vostro 3460 and no network devices are detected (ethernet and wireless).

when I run lspic, I see: 1:00.0 Network controller: Broadcom Corporation BCM43142 821.11b/g/n (rev 01) 2:00.0 Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet (rev 10)

Any ideas? Keep in mind my only internet connection is just another computer I'm using, so for installing stuff from the internet I would need to first download them, put them on a USB stick and then copy them and install on the Dell computer.


[Edit] One more thing, 'rfkill list all' lists only the bluetooth device.

[Edit] Ethernet works now, Wireless driver installed, but not functioning.

  • 2
    askubuntu.com/a/60395/88802 may help with your broadcom device – Chris Carter Jan 12 '13 at 11:06
  • All those steps suggested there require some sort of an internet connection. I could do this with a cable, but I don't even have that option. – Amit Jan 12 '13 at 11:21
  • run rfkill list in terminal to make sure there is no hard/software block on your devices. Paste the results into your question. – Chris Carter Jan 12 '13 at 11:26
  • I added that now, only bluetooth is listed – Amit Jan 12 '13 at 11:30
  • 1
    askubuntu.com/questions/217361/… This may just be what you are looking for – Chris Carter Jan 12 '13 at 11:38

The simplest thing to do and which doesn't seem to have been suggested yet, is to open Additional Drivers (jockey-gtk), and check if you can install the proprietary drivers for your wireless card (if any). Then I would suggest a precautionary reboot. If it still doesn't work, right-click NetworkManager ensure that Enable Wireless is checked. If it still doesn't work, then double-check wireless connectivity using wicd-gtk (sudo apt-get install wicd).

| improve this answer | |

@chris-carter hit the answer on the head in the comments section. Since you have the ethernet nic up and running, you should be able to just hardwire yourself in to your route and run:

sudo apt-get update sudo apt-get install b43-fwcutter

In the past, that's done the trick for me, and I hope it gets you up and running. Have a great day, and good luck!

Here is a ref for the b43 official Ubuntu Community wiki: Ubuntu B43 Wiki

| improve this answer | |

Make sure your laptop does not have a hardware button for turning off your wireless. you can also check in BIOS if it is disabled. otherwise I sometimes have problem with network in ubunut, and then I simply use the "debian" ways, e.g. edit

pico /etc/networking/interfaces

and use tools such as

ifup eth0



to setup and test network equipment.

| improve this answer | |

maybe you should try connecting using manual method,

sudo iwlist wlan0 scan - to scan for any AP

sudo iwconfig wlan0 essid "ssid"

sudo iwconfig wlan0 key "password"

sudo dhclient wlan0 - configure the network / obtaining ip address

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.