I managed to install Ubuntu 12.10 with the option acpi=off, as it didn't work without.

Now it boots only with this option. Is it possible to solve the problem for the need of this option? With this option it is booting is quite slow.

Could it be related to the Nvidia GeForce GT 520M card I have with Optimus technology? Maybe its drivers?

My laptop is a one year old ASPIRE 5750G.

  • acpi=off could be dangerous sometime. I never had issue with booting optimus. Make sure, you have updated your BIOS. – Web-E Jan 12 '13 at 9:21
  • How old is this computer? – user92200 Jan 12 '13 at 9:59
  • Using the same laptop as in your other question? – gertvdijk Jan 12 '13 at 13:43

The OP (Marce) found a solution. On 12/1/2012 the OP said:

I finally solved the problem following the instructions given by Arttu at the question Desktop does not show when I installed nvidia drivers!. The problem was about the nvidia drivers.

This is the answer to which the OP was referring.

Normally we'd close this as a duplicate of that question, but gertvdijk's answer here is valuable and addresses this but not that.


Turning ACPI off on a mobile PC (laptop/notebook) is not a good idea - it disables all power management you really want on those devices.

The root cause is probably a 'broken' BIOS that presents a false, corrupt or confusing ACPI table to the kernel. It may have been noticed by others and a workaround could be available. Also, your laptop vendor may have fixed this.

Some options I see you have from here (in your now somewhat vague but general situation):

  • Note that the kernel in the image to install Ubuntu is older than what is now 'stable', as some updates have been made available after the release. First thing to try is to apply all system updates and temporarily remove the boot parameter. Boot into Grub holding Shift, select the right entry, press E, remove the acpi=off kernel parameter and boot with F10. Keep using this with all options below to try!

  • Try to boot with acpi_osi=Linux as kernel parameter.

  • Upgrade to a more recent kernel. See this answer on how to do that.

  • Try to see if your laptop vendor has a BIOS update available. Apply it if so.

  • Try to boot with just one graphics card. Disable the discrete/Nvidia one and try also with the integrated one disabled.

  • In case you have an Nvidia Optimus enabled machine (hybrid graphics, often found in laptops), try to install Bumblebee for proper support of this technique. You can find some instructions in this answer.

  • Try to see if you have OS/ACPI specific settings in your BIOS.

  • Google around using your device vendor/type combination together with the keyword 'Linux'. Another distribution may have fixed it, someone may have proposed it to the kernel developers, but it may not have been merged in the main kernel tree yet, etc.

  • Report it as a bug. How do I report a bug?

Once you've managed to fix the issue, remove the kernel parameter permanently by removing in from the file /etc/default/grub and running sudo update-grub. (And if your solution was to boot with another kernel boot paramater, just edit the GRUB_CMDLINE_LINUX_DEFAULT setting accordingly in that file.)

If you have more specific information on that and need assistance, make it a new question, e.g. "How do I apply this workaround for my HP Probook... ?"

  • Bad thing... it seems really difficult to fix. You're talking about bios upgrading but I looked around in the internet and everywhere there's written that it is a difficult and dangerous procedure. Moreover I have no idea on how to disable the graphics cards and don't have any idea on what a kernel is. @acematrix : my computer is just one year old. It is an ASPIRE 5750G. – Marce Jan 12 '13 at 13:43
  • @Marce Yeah, but really, your hardware is the cause here. Workarounds are not nice things to apply. – gertvdijk Jan 12 '13 at 13:48
  • with bumblebee and the right drivers (actually i'm not sure of what i'm talking about, just followed some "howto") i solved the problem. Now I don't need anymore to set acpi=off when booting the system. Thank you anyway for your help! – Marce Jan 12 '13 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.