Possible Duplicate:
Set up USB for Virtualbox

Recently I installed Windows in Ubuntu 12.04.1 LTS using Virtualbox.

I want to know how to access external hard disks or USBs in the Virtual Windows 7.

When I plug in external storage device, only Ubuntu is detecting it. But the Virtual Windows 7 is unable to detect it and I can't access it from Windows 7. How can I link the files between Ubuntu and parallel Windows so that files can be shared in each OS at the same time?

  • Welcome to Ask Ubuntu! "I installed parallel windows" What is this parallel windows? and how is it related to the VirtualBox/Windows installation? Would you like to share files only or do you need USB-level access to devices from within Windows inside Virtualbox?
    – gertvdijk
    Jan 12 '13 at 2:51
  • What I meant by parallel windows is 'installing windows 7 using virtualbox in Ubuntu'. What I want and my problem is after plug in external storage device, I can access it only in Ubuntu. Can't access in the windows in virtualbox
    – Anu
    Jan 12 '13 at 3:40
  • 2
    @Anu please check this answer
    – Mochan
    Jan 12 '13 at 3:44
  • 1

I found the solution for this. First you need to install gnome-system-tools. You can do it by typing the command sudo apt-get install gnome-system-tools Once finished, open user and groups from launcher. Click on manage groups --> vboxusers. Add a user and then logout and login. After that boot your guest OS and right click on the USB option as shown in the picture and choose your external storage device there

enter image description here

After choose the correct usb device open virtualbox --> settings--> USB and click on the + sign and you can see your USB device is added there. You should enable the USB2.0(EHCI) controller as well prior to this.

Take note that, you can use the USB only in one OS at one time. Either in your guest or in host. You can do it by uncheck/check the USB device

Issue solved!

  • In terminal sudo usermod -G vboxusers -a yourusername
    – Jon Hulka
    Jun 15 '18 at 15:25

If I'm not mistaken the Open Source version of VirtualBox that comes in the Ubuntu repositories does not have USB access enabled. You have to install the version found in VirtualBox's website which does have USB support enabled.


You may need to upgrade to PUEL Version.

Also, though it's not recommended, try running Virtualbox as root to see if the issue is still there. I once have my integrated webcam unrecognized by the guest OS and this solved the problem.

  • Hi Navie, How can I upgrade PUEL? By the way what is PUEL?
    – Anu
    Jan 12 '13 at 3:42
  • Google gave me this: Personal Use and Evaluation License (PUEL).
    – user25656
    Jan 12 '13 at 3:47
  • 1
    Just follow the instruction in the thread I gave. By upgrading to PUEL, I meant downloading and installing the extension pack (virtualbox.org/wiki/Downloads)
    – boh
    Jan 12 '13 at 5:29
  • 1
    btw, I am not sure about this but as what I know, your external drive can only be mounted on either Windows 7 or Ubuntu, not both of them. For your purpose, you may try "sharing folder" function. The idea is to mount the external drive in Ubuntu and share that directory (on your Host OS) with the Guest OS (Windows 7). See helpdeskgeek.com/virtualization/…
    – boh
    Jan 12 '13 at 5:37
  • 1
    How's about Help->about for checking the current version? There are many issues reported with the USB devices on Virtual Box. I recommend you to try sharing folder from Host to Guest OS first. And it seems that I (and other people here) misunderstood your problem in the first place. What you probably need is the sharing function, not mounting external drive on your Guest OS.
    – boh
    Jan 12 '13 at 5:44

in VirtualBox>>settings>>USB>>use "+" button to add and manage USB device.

  • I tried to add usb in virtual box. But it is showing error 'USB2.0 is currently enabled for this virtual machine. However, this requires the Oracle VM VirtualBox Extension Pack to be installed. Please install the extension pack. But am not sure from where to install this extension pack. Tried to find in software center. But not available there...
    – Anu
    Jan 12 '13 at 4:28
  • Here is the link
    – Sandeep
    Jan 12 '13 at 6:24
  • Already updated. But still when i press + it is showing no device found.
    – Anu
    Jan 12 '13 at 7:08
  • 1
    When click on the settings it also showing error 'Failed to access the USB subsystem. You can change this by adding your user to the 'vboxusers' group.
    – Anu
    Jan 12 '13 at 7:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.